summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-28 23:23:46 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-28 23:23:46 (GMT)
commit11fabfd693a5970ab30ca4460f8ec5aef3227beb (patch)
tree0dcdffaf55e06069bc0b8676c44607edd54ab582 /c++/src/Makefile.am
parent5b4232e9d164434e422bdd72199f39507af984d8 (diff)
downloadhdf5-11fabfd693a5970ab30ca4460f8ec5aef3227beb.zip
hdf5-11fabfd693a5970ab30ca4460f8ec5aef3227beb.tar.gz
hdf5-11fabfd693a5970ab30ca4460f8ec5aef3227beb.tar.bz2
[svn-r10108] Purpose:
Bug fix Description: C++ tests would die with strange linking-type errors. Solution: C++ build needs to be static, too. Applied -static flags liberally in c++/src and c++/test directories. Platforms tested: sleipnir, heping
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index daab94e..08cd88d 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -22,13 +22,13 @@ include $(top_srcdir)/config/commence.am
# Include src directory
INCLUDES=-I$(top_srcdir)/src
-# This is our main target
-lib_LTLIBRARIES=libhdf5_cpp.la
-
# Build the library statically because some compliers can only link one
# dynamic library, and that's the main hdf5 library (which is much larger
# than this one).
-libhdf5_cpp_la_LDFLAGS=-static
+AM_LDFLAGS=-static
+
+# This is our main target
+lib_LTLIBRARIES=libhdf5_cpp.la
bin_SCRIPTS=h5c++