summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-07-21 19:28:11 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-07-21 19:28:11 (GMT)
commit7236935a9d666926b5843f317a84743ef3d4126a (patch)
tree21d7f4f7d0fbc1348c374ba39f9b2ca095841e81 /c++/src/Makefile.am
parentbb31e94a924a1b3f6f1da6c10ffe95029c87d5c5 (diff)
downloadhdf5-7236935a9d666926b5843f317a84743ef3d4126a.zip
hdf5-7236935a9d666926b5843f317a84743ef3d4126a.tar.gz
hdf5-7236935a9d666926b5843f317a84743ef3d4126a.tar.bz2
[svn-r11095] Purpose:
Configuration feature Description: Serial test output is now stored in log files and printed when all tests in a directory complete, or when a test fails. This should make test output more readable and useful. Also made changes to clean up ii_files directories that are created by some C++ compilers/linkers. Also fixed a few minor Makefile bugs. Solution: When serial tests run, their output is saved in *.log or *.logsh. While running, tests only print when they begin and when they complete; their more specific output (from the log file) is printed if the test fails or when all tests have completed. Comments welcome. Platforms tested: mir, modi4 (parallel and serial), copper, shanti
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index 585f9c1..5c9a2de 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -53,6 +53,14 @@ include_HEADERS=H5Cpp.h H5AbstractDs.h H5AtomType.h H5Attribute.h H5Classes.h
# distclean.
DISTCLEANFILES=h5c++ libhdf5.settings
+# Some C++ compilers/linkers (PGI?) create a directory named "ii_files" that
+# holds *.ii files, which are template entity instantiations.
+# This entire directory should be cleaned.
+mostlyclean-local:
+ if test -d ii_files; then \
+ $(RM) -rf ii_files; \
+ fi
+
# Mark this directory as part of the C++ API
HDF_CXX=yes