summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2015-10-06 04:31:58 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2015-10-06 04:31:58 (GMT)
commitf17eb1e6107fd7c86cbad2a16d66d0c18f4a6959 (patch)
tree57521002160558658dcf6d7596e5cc66b2f06aaf /c++/src/Makefile.am
parent0fb60ee7aeb183adcc188302b76b660aeaf8d41e (diff)
downloadhdf5-f17eb1e6107fd7c86cbad2a16d66d0c18f4a6959.zip
hdf5-f17eb1e6107fd7c86cbad2a16d66d0c18f4a6959.tar.gz
hdf5-f17eb1e6107fd7c86cbad2a16d66d0c18f4a6959.tar.bz2
[svn-r27961] Purpose: Partial fix of issues HDFFV-9169 and HDFFV-9167
Description: Added wrappers for H5P[s/g]et_attr_phase_change and H5P[s/g]et_attr_creation_order // Sets attribute storage phase change thresholds. void setAttrPhaseChange(unsigned max_compact = 8, unsigned min_dense = 6) // Gets attribute storage phase change thresholds. void getAttrPhaseChange(unsigned& max_compact, unsigned& min_dense) // Sets tracking and indexing of attribute creation order. void setAttrCrtOrder(unsigned crt_order_flags) // Gets tracking and indexing settings for attribute creation order. unsigned getAttrCrtOrder() Platforms tested: Linux/32 2.6 (jam) Linux/64 (platypus) Darwin (osx1010test)
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index cdef7bf..84af348 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -36,10 +36,10 @@ bin_SCRIPTS=h5c++
libhdf5_cpp_la_SOURCES=H5Exception.cpp H5IdComponent.cpp H5Library.cpp \
H5Attribute.cpp H5Location.cpp H5Object.cpp H5PropList.cpp \
H5FaccProp.cpp H5FcreatProp.cpp H5DcreatProp.cpp H5DxferProp.cpp \
- H5DataType.cpp H5DataSpace.cpp H5AbstractDs.cpp H5AtomType.cpp \
- H5PredType.cpp H5EnumType.cpp H5IntType.cpp H5FloatType.cpp \
- H5StrType.cpp H5ArrayType.cpp H5VarLenType.cpp H5CompType.cpp \
- H5DataSet.cpp H5CommonFG.cpp H5Group.cpp H5File.cpp
+ H5OcreatProp.cpp H5DataType.cpp H5DataSpace.cpp H5AbstractDs.cpp \
+ H5AtomType.cpp H5PredType.cpp H5EnumType.cpp H5IntType.cpp \
+ H5FloatType.cpp H5StrType.cpp H5ArrayType.cpp H5VarLenType.cpp \
+ H5CompType.cpp H5DataSet.cpp H5CommonFG.cpp H5Group.cpp H5File.cpp
# HDF5 C++ library depends on HDF5 Library.
libhdf5_cpp_la_LIBADD=$(LIBHDF5)
@@ -47,11 +47,11 @@ libhdf5_cpp_la_LIBADD=$(LIBHDF5)
# Public headers
include_HEADERS=H5Cpp.h H5AbstractDs.h H5AtomType.h H5Attribute.h H5Classes.h \
H5CommonFG.h H5CompType.h H5DataSet.h H5DataSpace.h H5DataType.h \
- H5DcreatProp.h H5DxferProp.h H5EnumType.h H5Exception.h H5FaccProp.h \
- H5FcreatProp.h H5File.h H5FloatType.h H5Group.h H5IdComponent.h \
- H5Include.h H5IntType.h H5Library.h H5Location.h H5Object.h \
- H5PredType.h H5PropList.h H5StrType.h H5CppDoc.h H5ArrayType.h \
- H5VarLenType.h
+ H5OcreatProp.h H5DcreatProp.h H5DxferProp.h H5EnumType.h \
+ H5Exception.h H5FaccProp.h H5FcreatProp.h H5File.h H5FloatType.h \
+ H5Group.h H5IdComponent.h H5Include.h H5IntType.h H5Library.h \
+ H5Location.h H5Object.h H5PredType.h H5PropList.h H5StrType.h \
+ H5CppDoc.h H5ArrayType.h H5VarLenType.h
# h5c++ and libhdf5.settings are generated during configure. Remove only when
# distclean.