summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-05-20 01:29:26 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-05-20 01:29:26 (GMT)
commit4344cf539168e127f87c6f86171bc3cbd66e4032 (patch)
tree0a37970e35bf7156347d178fd809a9cb566fe4d6 /c++/src/Makefile.am
parent6631ced7a910a7fd9b7752faae0b1321979dd009 (diff)
downloadhdf5-4344cf539168e127f87c6f86171bc3cbd66e4032.zip
hdf5-4344cf539168e127f87c6f86171bc3cbd66e4032.tar.gz
hdf5-4344cf539168e127f87c6f86171bc3cbd66e4032.tar.bz2
[svn-r15042] Bug fix.
Description: The fortran Makefile.am used HDF_FORTRAN to indicate it is part of the Fortran API source so that conclude.am will give fortran api prefix in the test output. The symbox HDF_FORTRAN is also used in configure for a different purpose (indicated --enable-fortran). They conflicted. Similar problem for the symbol HDF_CXX. Solution: Changed all the involved Makefile.am to use "FORTRAN_API" instead. It is a more appropriate name. Same for CXX_API. Along the way, discovered that the Makefile.am of hl/fortran/test and hl/cxx/test did not have those symbols at all. Added them in. Platform tested: Kagiso serial and h5committested (kagisopp, smirom, linew).
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index e63b827..3b1ed0d 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -64,6 +64,6 @@ mostlyclean-local:
fi
# Mark this directory as part of the C++ API
-HDF_CXX=yes
+CXX_API=yes
include $(top_srcdir)/config/conclude.am