summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-10-15 17:08:41 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-10-15 17:08:41 (GMT)
commitdd4360dccfda32f477192bd4a4ee22ee24585cf0 (patch)
tree1a6d58a5ddaa88dfdac2e558e0ea65f38da73581 /c++/src/Makefile.am
parent2a2a49f42280220ad7cf2c45b1e5103d3b72146a (diff)
downloadhdf5-dd4360dccfda32f477192bd4a4ee22ee24585cf0.zip
hdf5-dd4360dccfda32f477192bd4a4ee22ee24585cf0.tar.gz
hdf5-dd4360dccfda32f477192bd4a4ee22ee24585cf0.tar.bz2
[svn-r17645] Purpose:
Merge from Trunk Description: Merging all of my CFLAGS-related changes from trunk to 1.8 This includes revision #s: 17616, 17625, 17627, 17639, and 17643. Tested: h5committest and some additional checks on our FreeBSD as well as NCSA's machines.
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index c18b990..5cde27b 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -28,12 +28,12 @@ INCLUDES=-I$(top_srcdir)/src
lib_LTLIBRARIES=libhdf5_cpp.la
# Add libtool numbers to the HDF5 C++ library (from config/lt_vers.am)
-libhdf5_cpp_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
+libhdf5_cpp_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
# Shared C++ libraries aren't universally supported.
if CXX_SHARED_CONDITIONAL
else
- AM_LDFLAGS=-static
+ AM_LDFLAGS+=-static
endif
bin_SCRIPTS=h5c++