summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-25 19:34:54 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-25 19:34:54 (GMT)
commitb018ba48ced579975e60362e3acfb6afb1f1d384 (patch)
tree6aa56f1b84f2a5734964a72faefc33280e3cce47 /c++/src/Makefile.am
parentbbaec6dfe44e8878345de2594dc97f1bc8d361ba (diff)
downloadhdf5-b018ba48ced579975e60362e3acfb6afb1f1d384.zip
hdf5-b018ba48ced579975e60362e3acfb6afb1f1d384.tar.gz
hdf5-b018ba48ced579975e60362e3acfb6afb1f1d384.tar.bz2
[svn-r25106] Removed LT_ADD_LIBHDF5_DEPENDENCY configure conditional to roll back fix for removing rpaths from lib files. The fix also removed dependencies on libhdf5, etc. when the --disable-sharedlib-rpath configure option was invoked.
Added instead configure variable hardcode_into_lib=no. This removes rpath from lib files on Linux and solaris machines. Tested with h5committest on jam, koala, ostrich and platypus (cmake), and on emu and kite.
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index 9ff2e66..7c1f497 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -47,11 +47,8 @@ libhdf5_cpp_la_SOURCES=H5Exception.cpp H5IdComponent.cpp H5Library.cpp \
H5StrType.cpp H5ArrayType.cpp H5VarLenType.cpp H5CompType.cpp \
H5DataSet.cpp H5CommonFG.cpp H5Group.cpp H5File.cpp
-# HDF5 C++ library depends on HDF5 Library. However, only add the dependency
-# if --enable-sharedlib-rpath is yes.
-if LT_ADD_LIBHDF5_DEPENDENCY
+# HDF5 C++ library depends on HDF5 Library.
libhdf5_cpp_la_LIBADD=$(LIBHDF5)
-endif
# Public headers
include_HEADERS=H5Cpp.h H5AbstractDs.h H5AtomType.h H5Attribute.h H5Classes.h \