summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2007-06-28 20:36:08 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2007-06-28 20:36:08 (GMT)
commit58467956ba56fc52dd03e3540f14b062f9a6c5bb (patch)
treeddff2bedfd24083e8a180e1492fa169160104e67 /c++/src/Makefile.am
parent10f04e651970fde07a8ac61e92359eaaad977571 (diff)
downloadhdf5-58467956ba56fc52dd03e3540f14b062f9a6c5bb.zip
hdf5-58467956ba56fc52dd03e3540f14b062f9a6c5bb.tar.gz
hdf5-58467956ba56fc52dd03e3540f14b062f9a6c5bb.tar.bz2
[svn-r13925] Purpose: intermediate checkin for offsetof fix for PGI compiler.
Description: added new configuration to generate a pubconf file in the c++/src directory, H5cxx_pubconf.h. When C++ compiler recognizes 'offsetof', the macro H5_CXX_HAVE_OFFSETOF is defined in the new pubconf file. tested: kagiso, smirom
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index db16458..a9232b1 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -49,11 +49,12 @@ include_HEADERS=H5Cpp.h H5AbstractDs.h H5AtomType.h H5Attribute.h H5Classes.h \
H5DcreatProp.h H5DxferProp.h H5EnumType.h H5Exception.h H5FaccProp.h \
H5FcreatProp.h H5File.h H5FloatType.h H5Group.h H5IdComponent.h \
H5Include.h H5IntType.h H5Library.h H5Object.h H5PredType.h \
- H5PropList.h H5StrType.h H5CppDoc.h H5ArrayType.h H5VarLenType.h
+ H5PropList.h H5StrType.h H5CppDoc.h H5ArrayType.h H5VarLenType.h \
+ H5cxx_pubconf.h
# h5c++ and libhdf5.settings are generated during configure. Remove only when
# distclean.
-DISTCLEANFILES=h5c++ libhdf5.settings
+DISTCLEANFILES=h5c++ libhdf5.settings H5cxx_pubconf.h
# Some C++ compilers/linkers (PGI?) create a directory named "ii_files" that
# holds *.ii files, which are template entity instantiations.