summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:00:11 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2009-04-20 06:00:11 (GMT)
commitbc36a358d115d1cddc7328e61a44558c023d20fd (patch)
treef4c8f79102fc8decb73d04c8706418216a0676a8 /c++/src/Makefile.am
parent476cbeda792322fb66600eeb7022d303bd55d7c7 (diff)
downloadhdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.zip
hdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.tar.gz
hdf5-bc36a358d115d1cddc7328e61a44558c023d20fd.tar.bz2
[svn-r16792] Description:
- Updated bin/reconfigure to use latest version of automake (1.10.2). Re-generated Makefile.in's by running bin/reconfigure. - Added libtool version numbers to c++, fortran, hl, hl c++, and hl fortran libraries. Tested: jam, liberty, smirom
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index 3b1ed0d..c18b990 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -19,6 +19,7 @@
#
include $(top_srcdir)/config/commence.am
+include $(top_srcdir)/config/lt_vers.am
# Include src directory
INCLUDES=-I$(top_srcdir)/src
@@ -26,6 +27,9 @@ INCLUDES=-I$(top_srcdir)/src
# This is our main target
lib_LTLIBRARIES=libhdf5_cpp.la
+# Add libtool numbers to the HDF5 C++ library (from config/lt_vers.am)
+libhdf5_cpp_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE)
+
# Shared C++ libraries aren't universally supported.
if CXX_SHARED_CONDITIONAL
else