summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-05-19 05:06:51 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-05-19 05:06:51 (GMT)
commitca94c839d55e383f541c9713e0a0aa085a0572af (patch)
treed0ec359b7855d254734ea7c5cc9d6bde383add62 /c++/src/Makefile.am
parent2adc43f81221954e16da3338445323f1e4d958ad (diff)
downloadhdf5-ca94c839d55e383f541c9713e0a0aa085a0572af.zip
hdf5-ca94c839d55e383f541c9713e0a0aa085a0572af.tar.gz
hdf5-ca94c839d55e383f541c9713e0a0aa085a0572af.tar.bz2
[svn-r15036] Bug fix.
Description: The fortran Makefile.am used HDF_FORTRAN to indicate it is part of the Fortran API source so that conclude.am will give fortran api prefix in the test output. The symbox HDF_FORTRAN is also used in configure for a different purpose (indicated --enable-fortran). They conflicted. Similar problem for the symbol HDF_CXX. Solution: Changed all the involved Makefile.am to use "FORTRAN_API" instead. It is a more appropriate name. Same for CXX_API. Along the way, discovered that the Makefile.am of hl/fortran/test and hl/cxx/test did not have those symbols at all. Added them in. Platform tested: Kagiso only. It is a trivia change.
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index e63b827..3b1ed0d 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -64,6 +64,6 @@ mostlyclean-local:
fi
# Mark this directory as part of the C++ API
-HDF_CXX=yes
+CXX_API=yes
include $(top_srcdir)/config/conclude.am