summaryrefslogtreecommitdiffstats
path: root/c++/src/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2018-07-24 04:41:56 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2018-07-24 04:41:56 (GMT)
commit98308480f6fbb97d9a273334db714c4c967fd6c9 (patch)
treec4c4ad86525962217a3cd25508b2c6f3c489b89f /c++/src/Makefile.am
parent243a36911fb80931225e0044cc654ccbfec3ed10 (diff)
parent3c6a39858fef9e7207cd7c3e3057267ec380be0b (diff)
downloadhdf5-98308480f6fbb97d9a273334db714c4c967fd6c9.zip
hdf5-98308480f6fbb97d9a273334db714c4c967fd6c9.tar.gz
hdf5-98308480f6fbb97d9a273334db714c4c967fd6c9.tar.bz2
Merge pull request #1146 in HDFFV/hdf5 from ~BMRIBLER/hdf5_bmr_cpp4:develop to develop
Code improvement New class for dataset access property list * commit '3c6a39858fef9e7207cd7c3e3057267ec380be0b': Fixed typos Entered entries for HDFFV-10150, HDFFV-10458, HDFFV-1047 Updated for C2Cppfunction_map.htm Added class DSetAccPropList Description: - Added class DSetAccPropList for the dataset access property list. - Added wrapper for H5Dget_access_plist to class DataSet // Gets the access property list of this dataset. DSetAccPropList getAccessPlist() const; Code improvement Description: Moved the new H5Object::getInfo member functions to H5Location and made them overloaded with the existing H5Location::getObjinfo. This way is cleaner than the previous approach. Platforms tested: Linux/64 (jelly) Linux/32 (jam) Darwin (osx1010test)
Diffstat (limited to 'c++/src/Makefile.am')
-rw-r--r--c++/src/Makefile.am22
1 files changed, 12 insertions, 10 deletions
diff --git a/c++/src/Makefile.am b/c++/src/Makefile.am
index c02a9e7..ca42211 100644
--- a/c++/src/Makefile.am
+++ b/c++/src/Makefile.am
@@ -34,21 +34,23 @@ bin_SCRIPTS=h5c++
libhdf5_cpp_la_SOURCES=H5Exception.cpp H5IdComponent.cpp \
H5DataSpace.cpp H5PropList.cpp H5Library.cpp \
H5FaccProp.cpp H5FcreatProp.cpp H5LcreatProp.cpp \
- H5LaccProp.cpp H5DxferProp.cpp H5DcreatProp.cpp \
- H5Location.cpp H5AbstractDs.cpp H5Attribute.cpp \
- H5Object.cpp H5OcreatProp.cpp H5DataType.cpp \
- H5AtomType.cpp H5PredType.cpp H5EnumType.cpp \
- H5IntType.cpp H5FloatType.cpp H5StrType.cpp \
- H5ArrayType.cpp H5VarLenType.cpp H5CompType.cpp \
- H5DataSet.cpp H5CommonFG.cpp H5Group.cpp H5File.cpp
+ H5LaccProp.cpp H5DaccProp.cpp H5DxferProp.cpp \
+ H5DcreatProp.cpp H5Location.cpp H5AbstractDs.cpp \
+ H5Attribute.cpp H5Object.cpp H5OcreatProp.cpp \
+ H5DataType.cpp H5AtomType.cpp H5PredType.cpp \
+ H5EnumType.cpp H5IntType.cpp H5FloatType.cpp \
+ H5StrType.cpp H5ArrayType.cpp H5VarLenType.cpp \
+ H5CompType.cpp H5DataSet.cpp H5CommonFG.cpp H5Group.cpp \
+ H5File.cpp
# HDF5 C++ library depends on HDF5 Library.
libhdf5_cpp_la_LIBADD=$(LIBHDF5)
# Public headers
-include_HEADERS=H5Cpp.h H5AbstractDs.h H5AtomType.h H5Attribute.h \
- H5Classes.h H5CommonFG.h H5CompType.h H5DataSet.h \
- H5DataSpace.h H5DataType.h H5OcreatProp.h H5DcreatProp.h\
+include_HEADERS=H5Cpp.h H5AbstractDs.h H5AtomType.h \
+ H5Attribute.h H5Classes.h H5CommonFG.h H5CompType.h \
+ H5DataSet.h H5DataSpace.h H5DataType.h H5OcreatProp.h \
+ H5DaccProp.h H5DcreatProp.h
H5DxferProp.h H5EnumType.h H5Exception.h H5FaccProp.h \
H5FcreatProp.h H5File.h H5FloatType.h H5Group.h \
H5IdComponent.h H5Include.h H5IntType.h H5LcreatProp.h \