summaryrefslogtreecommitdiffstats
path: root/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2016-01-18 15:06:51 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2016-01-18 15:06:51 (GMT)
commit4d6662e86c03e783c8d574dd50941edb607a07ca (patch)
tree1cdd35a160bebf4ba981b2f439e2780db354bc1c /c++/test/CMakeLists.txt
parent7c2b004f25da184a59fc4892eb6dec2997e96154 (diff)
downloadhdf5-4d6662e86c03e783c8d574dd50941edb607a07ca.zip
hdf5-4d6662e86c03e783c8d574dd50941edb607a07ca.tar.gz
hdf5-4d6662e86c03e783c8d574dd50941edb607a07ca.tar.bz2
[svn-r28926] Purpose: Fix user reported problem
Description: User Adam Rosenberger reported a failure when using the member function AbstractDs::getArrayType(). This problem was caused by missing initialization of the ArrayType's members in some cases. Solution: - Added ArrayType::setArrayInfo() to retrieve rank and dimensions of an array and store them in memory for easy access. - Re-factored a few functions to use the new function. - We'll give him 1.8.16 patch Merged from trunk r28905 Platforms tested: Linux/32 2.6 (jam) Linux/64 (platypus) Darwin (osx1010test)
Diffstat (limited to 'c++/test/CMakeLists.txt')
-rw-r--r--c++/test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/c++/test/CMakeLists.txt b/c++/test/CMakeLists.txt
index 6f1d857..4bebeac 100644
--- a/c++/test/CMakeLists.txt
+++ b/c++/test/CMakeLists.txt
@@ -13,6 +13,7 @@ PROJECT (HDF5_CPP_TEST)
#-----------------------------------------------------------------------------
set (CPP_TEST_SRCS
${HDF5_CPP_TEST_SOURCE_DIR}/testhdf5.cpp
+ ${HDF5_CPP_TEST_SOURCE_DIR}/tarray.cpp
${HDF5_CPP_TEST_SOURCE_DIR}/tattr.cpp
${HDF5_CPP_TEST_SOURCE_DIR}/tcompound.cpp
${HDF5_CPP_TEST_SOURCE_DIR}/tdspl.cpp