summaryrefslogtreecommitdiffstats
path: root/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-05-05 20:57:40 (GMT)
committerGitHub <noreply@github.com>2023-05-05 20:57:40 (GMT)
commit4b228ec6af3c53956fba7822c0ae808d3d3e2cb3 (patch)
tree134559dc3c077697845f0158e9da73162210ff2f /c++/test/CMakeLists.txt
parentcc4d63b026dd0c392adc28e90a14eec47cb10bdd (diff)
downloadhdf5-4b228ec6af3c53956fba7822c0ae808d3d3e2cb3.zip
hdf5-4b228ec6af3c53956fba7822c0ae808d3d3e2cb3.tar.gz
hdf5-4b228ec6af3c53956fba7822c0ae808d3d3e2cb3.tar.bz2
Fix CMake generator expression syntax (#2909)
Diffstat (limited to 'c++/test/CMakeLists.txt')
-rw-r--r--c++/test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/c++/test/CMakeLists.txt b/c++/test/CMakeLists.txt
index 55aade2..308bc3b 100644
--- a/c++/test/CMakeLists.txt
+++ b/c++/test/CMakeLists.txt
@@ -41,7 +41,7 @@ add_executable (cpp_testhdf5 ${CPP_TEST_SOURCES} ${HDF5_CPP_TEST_SOURCE_DIR}/h5c
target_include_directories (cpp_testhdf5 PRIVATE "${HDF5_SRC_INCLUDE_DIRS};${HDF5_SRC_BINARY_DIR};${HDF5_TEST_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
target_compile_options(cpp_testhdf5 PRIVATE "${HDF5_CMAKE_CXX_FLAGS}")
target_compile_definitions(cpp_testhdf5
- PRIVATE $<$<BOOL:${HDF5_ENABLE_PARALLEL}>:MPICH_SKIP_MPICXX;MPICH_IGNORE_CXX_SEEK># Parallel/MPI, prevent spurious cpp/cxx warnings
+ PRIVATE "$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:MPICH_SKIP_MPICXX;MPICH_IGNORE_CXX_SEEK>"# Parallel/MPI, prevent spurious cpp/cxx warnings
)
if (NOT BUILD_SHARED_LIBS)
TARGET_C_PROPERTIES (cpp_testhdf5 STATIC)