summaryrefslogtreecommitdiffstats
path: root/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-08-23 16:07:43 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-08-23 16:07:43 (GMT)
commit1f8fb63581b72b1618e0540032ca5f3d682ebcb2 (patch)
treec051f004c36a19e8ba42088d45c605cc1533eb5c /c++/test/CMakeLists.txt
parentcac6687a6a4adcfff526d91f3b57671089ef10b5 (diff)
downloadhdf5-1f8fb63581b72b1618e0540032ca5f3d682ebcb2.zip
hdf5-1f8fb63581b72b1618e0540032ca5f3d682ebcb2.tar.gz
hdf5-1f8fb63581b72b1618e0540032ca5f3d682ebcb2.tar.bz2
[svn-r22709] HDFFV-8129: reconfigured on jam, Remove overloading of autotools TESTS var, rename configure.in to configure.ac, convert test scripts from hard *.sh to configure managed *sh.in files.
Tested: h5committest
Diffstat (limited to 'c++/test/CMakeLists.txt')
-rw-r--r--c++/test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/c++/test/CMakeLists.txt b/c++/test/CMakeLists.txt
index fa5e2fd..7f4437c 100644
--- a/c++/test/CMakeLists.txt
+++ b/c++/test/CMakeLists.txt
@@ -44,6 +44,13 @@ TARGET_LINK_LIBRARIES (cpp_testhdf5
)
SET_TARGET_PROPERTIES (cpp_testhdf5 PROPERTIES FOLDER test/cpp)
+ADD_CUSTOM_COMMAND (
+ TARGET cpp_testhdf5
+ POST_BUILD
+ COMMAND ${CMAKE_COMMAND}
+ ARGS -E copy_if_different ${HDF5_CPP_TEST_SOURCE_DIR}/th5s.h5 ${PROJECT_BINARY_DIR}/th5s.h5
+)
+
ADD_TEST (NAME cpp_testhdf5 COMMAND $<TARGET_FILE:cpp_testhdf5>)
IF (HDF5_TEST_VFD)