summaryrefslogtreecommitdiffstats
path: root/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-04-20 15:11:55 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-04-20 15:11:55 (GMT)
commit6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8 (patch)
treeea96affc668bcf047a1e97fbb9cc889892a2d9a9 /c++/test/CMakeLists.txt
parentb68321b2b3647b23b0820d958ec529c13be121ed (diff)
downloadhdf5-6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8.zip
hdf5-6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8.tar.gz
hdf5-6c82c49dd5e5ee187ab1da9f54311a1ecab45bb8.tar.bz2
TRILABS-20 set a compiler name on all project commands
Diffstat (limited to 'c++/test/CMakeLists.txt')
-rw-r--r--c++/test/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/c++/test/CMakeLists.txt b/c++/test/CMakeLists.txt
index 83ca337..abc7952 100644
--- a/c++/test/CMakeLists.txt
+++ b/c++/test/CMakeLists.txt
@@ -1,5 +1,19 @@
cmake_minimum_required (VERSION 3.10)
-PROJECT (HDF5_CPP_TEST)
+project (HDF5_CPP_TEST CXX)
+
+#-----------------------------------------------------------------------------
+# Parallel/MPI, prevent spurious cpp/cxx warnings
+#-----------------------------------------------------------------------------
+if (H5_HAVE_PARALLEL)
+ add_definitions ("-DMPICH_SKIP_MPICXX")
+ add_definitions ("-DMPICH_IGNORE_CXX_SEEK")
+endif ()
+
+#-----------------------------------------------------------------------------
+# Apply Definitions to compiler in this directory and below
+#-----------------------------------------------------------------------------
+add_definitions (${HDF_EXTRA_C_FLAGS})
+
# --------------------------------------------------------------------
# Notes: When creating unit test executables they should be prefixed
# with "cpp_". This allows for easier filtering of the test suite when