summaryrefslogtreecommitdiffstats
path: root/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-09-28 18:57:41 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-09-28 18:57:41 (GMT)
commit7c742a851847997f5e931f3d448b368c3179de32 (patch)
tree8908e35a0110298e3fc3e29120481e05798d5500 /c++/test/CMakeLists.txt
parent43ce4b5e6e5eb4e848bf1726252f1ca17212e545 (diff)
downloadhdf5-7c742a851847997f5e931f3d448b368c3179de32.zip
hdf5-7c742a851847997f5e931f3d448b368c3179de32.tar.gz
hdf5-7c742a851847997f5e931f3d448b368c3179de32.tar.bz2
Add clang-format changes from develop.
Diffstat (limited to 'c++/test/CMakeLists.txt')
-rw-r--r--c++/test/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/c++/test/CMakeLists.txt b/c++/test/CMakeLists.txt
index ca2295e..b911424 100644
--- a/c++/test/CMakeLists.txt
+++ b/c++/test/CMakeLists.txt
@@ -37,7 +37,7 @@ set (CPP_TEST_SOURCES
set (srcdir ${CMAKE_CURRENT_SOURCE_DIR})
configure_file (${HDF5_CPP_TEST_SOURCE_DIR}/H5srcdir_str.h.in H5srcdir_str.h @ONLY)
-add_executable (cpp_testhdf5 ${CPP_TEST_SOURCES} )
+add_executable (cpp_testhdf5 ${CPP_TEST_SOURCES} ${HDF5_CPP_TEST_SOURCE_DIR}/h5cpputil.h)
target_include_directories (cpp_testhdf5 PRIVATE "${HDF5_SRC_DIR};${HDF5_BINARY_DIR};${HDF5_TEST_BINARY_DIR};$<$<BOOL:${HDF5_ENABLE_PARALLEL}>:${MPI_C_INCLUDE_DIRS}>")
target_compile_options(cpp_testhdf5 PRIVATE "${HDF5_CMAKE_CXX_FLAGS}")
target_compile_definitions(cpp_testhdf5
@@ -57,6 +57,13 @@ else ()
endif ()
set_target_properties (cpp_testhdf5 PROPERTIES FOLDER test/cpp)
+#-----------------------------------------------------------------------------
+# Add Target to clang-format
+#-----------------------------------------------------------------------------
+if (HDF5_ENABLE_FORMATTERS)
+ clang_format (HDF5_CPP_TEST_cpp_testhdf5_FORMAT cpp_testhdf5)
+endif ()
+
if (HDF5_TEST_CPP AND HDF5_TEST_SERIAL)
include (CMakeTests.cmake)
endif ()