summaryrefslogtreecommitdiffstats
path: root/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-06-29 20:09:03 (GMT)
commit2f13382883e54af2d0584bb8b763ce6049d15826 (patch)
treea30ee54236fa8ab56bfc49b6f7b4523d6df191c1 /c++/test/CMakeLists.txt
parenteb5eba9aee6cb002b2a5278e00e232f4a2118bf6 (diff)
downloadhdf5-2f13382883e54af2d0584bb8b763ce6049d15826.zip
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.gz
hdf5-2f13382883e54af2d0584bb8b763ce6049d15826.tar.bz2
[svn-r19037] Added executable Linker Flag for MSVC static builds: /NODEFAULTLIB:MSVCRT
Added VERSION vars for inclusion into auto snapshot version update script Tested windows
Diffstat (limited to 'c++/test/CMakeLists.txt')
-rw-r--r--c++/test/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/c++/test/CMakeLists.txt b/c++/test/CMakeLists.txt
index ac72772..770348e 100644
--- a/c++/test/CMakeLists.txt
+++ b/c++/test/CMakeLists.txt
@@ -38,6 +38,16 @@ INCLUDE_DIRECTORIES (${HDF5_TEST_SOURCE_DIR} )
ADD_EXECUTABLE (cpp_testhdf5 ${CPP_TEST_SRCS} )
H5_NAMING (cpp_testhdf5)
+IF (WIN32)
+ IF (MSVC)
+ IF (NOT BUILD_SHARED_LIBS)
+ SET_TARGET_PROPERTIES (cpp_testhdf5
+ PROPERTIES
+ LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
+ )
+ ENDIF (NOT BUILD_SHARED_LIBS)
+ ENDIF (MSVC)
+ENDIF (WIN32)
TARGET_LINK_LIBRARIES (cpp_testhdf5
${HDF5_CPP_LIB_TARGET}
${HDF5_LIB_TARGET}