summaryrefslogtreecommitdiffstats
path: root/c++/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:30:23 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-09-09 16:30:23 (GMT)
commitbed127641399ec6c6e1479b7c394fd3a4eb56438 (patch)
treebd923e43fb7c5a004a94f038b6c087d1d170f739 /c++/test/CMakeLists.txt
parenta5b16bbd75dddc008480448d458cb0a1b7ba70fa (diff)
downloadhdf5-bed127641399ec6c6e1479b7c394fd3a4eb56438.zip
hdf5-bed127641399ec6c6e1479b7c394fd3a4eb56438.tar.gz
hdf5-bed127641399ec6c6e1479b7c394fd3a4eb56438.tar.bz2
[svn-r19361] Move Windows specific compile and link flags to macros
Diffstat (limited to 'c++/test/CMakeLists.txt')
-rw-r--r--c++/test/CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/c++/test/CMakeLists.txt b/c++/test/CMakeLists.txt
index 722bd37..e29963e 100644
--- a/c++/test/CMakeLists.txt
+++ b/c++/test/CMakeLists.txt
@@ -37,16 +37,7 @@ INCLUDE_DIRECTORIES (${HDF5_TEST_SRC_DIR} )
ADD_EXECUTABLE (cpp_testhdf5 ${CPP_TEST_SRCS} )
H5_NAMING (cpp_testhdf5)
-IF (WIN32)
- IF (MSVC)
- IF (NOT BUILD_SHARED_LIBS)
- SET_TARGET_PROPERTIES (cpp_testhdf5
- PROPERTIES
- LINK_FLAGS "/NODEFAULTLIB:MSVCRT"
- )
- ENDIF (NOT BUILD_SHARED_LIBS)
- ENDIF (MSVC)
-ENDIF (WIN32)
+TARGET_WIN_PROPERTIES (cpp_testhdf5)
TARGET_LINK_LIBRARIES (cpp_testhdf5
${HDF5_CPP_LIB_TARGET}
${HDF5_LIB_TARGET}