summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2016-01-18 15:06:51 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2016-01-18 15:06:51 (GMT)
commit4d6662e86c03e783c8d574dd50941edb607a07ca (patch)
tree1cdd35a160bebf4ba981b2f439e2780db354bc1c /c++/test/Makefile.am
parent7c2b004f25da184a59fc4892eb6dec2997e96154 (diff)
downloadhdf5-4d6662e86c03e783c8d574dd50941edb607a07ca.zip
hdf5-4d6662e86c03e783c8d574dd50941edb607a07ca.tar.gz
hdf5-4d6662e86c03e783c8d574dd50941edb607a07ca.tar.bz2
[svn-r28926] Purpose: Fix user reported problem
Description: User Adam Rosenberger reported a failure when using the member function AbstractDs::getArrayType(). This problem was caused by missing initialization of the ArrayType's members in some cases. Solution: - Added ArrayType::setArrayInfo() to retrieve rank and dimensions of an array and store them in memory for easy access. - Re-factored a few functions to use the new function. - We'll give him 1.8.16 patch Merged from trunk r28905 Platforms tested: Linux/32 2.6 (jam) Linux/64 (platypus) Darwin (osx1010test)
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index 705ec72..07fe533 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -31,9 +31,10 @@ check_PROGRAMS=$(TEST_PROG)
# The tests depend on the hdf5 library, test library, and the c++ library
LDADD=$(LIBH5TEST) $(LIBH5CPP) $(LIBHDF5)
-testhdf5_SOURCES=testhdf5.cpp dsets.cpp tattr.cpp tcompound.cpp \
- tdspl.cpp tfile.cpp tfilter.cpp th5s.cpp tlinks.cpp tobject.cpp \
- trefer.cpp ttypes.cpp tvlstr.cpp h5cpputil.cpp
+testhdf5_SOURCES=testhdf5.cpp dsets.cpp tattr.cpp tarray.cpp \
+ tcompound.cpp tdspl.cpp tfile.cpp tfilter.cpp th5s.cpp \
+ tlinks.cpp tobject.cpp trefer.cpp ttypes.cpp tvlstr.cpp \
+ h5cpputil.cpp
# Tell conclude.am that these are C++ tests.
CXX_API=yes