summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2010-03-17 03:40:01 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2010-03-17 03:40:01 (GMT)
commitb78157094308e0dbe1d76c11f769aee7bca92079 (patch)
tree5ab7b64ade08e0194bc4f6b77d3cd6219f0226f3 /c++/test/Makefile.am
parentdcf0727a9e3bb1c453efa51518c0133e5b4aed8b (diff)
downloadhdf5-b78157094308e0dbe1d76c11f769aee7bca92079.zip
hdf5-b78157094308e0dbe1d76c11f769aee7bca92079.tar.gz
hdf5-b78157094308e0dbe1d76c11f769aee7bca92079.tar.bz2
[svn-r18409] Description:
Removed header file testhdf5.h from C++ tests to eliminate a non-standard problem on OpenVMS. It wasn't essential. Also, moved dsets.cpp from a standalone program into testhdf5.cpp to be consistent with the rest of the tests. Platforms tested: Linux/32 2.6 (jam) FreeBSD/64 6.3 (liberty) SunOS 5.10 (linew) Will ask Ray to test on OpenVMS.
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index fdfdd61..687f0ca 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -31,15 +31,15 @@ endif
# These are our main targets. They should be listed in the order to be
# executed, generally most specific tests to least specific tests.
-TEST_PROG=dsets testhdf5
+TEST_PROG=testhdf5
check_PROGRAMS=$(TEST_PROG)
# The tests depend on the hdf5 library, test library, and the c++ library
LDADD=$(LIBH5TEST) $(LIBH5CPP) $(LIBHDF5)
-dsets_SOURCES=dsets.cpp h5cpputil.cpp
-testhdf5_SOURCES=testhdf5.cpp tattr.cpp tcompound.cpp tfile.cpp tfilter.cpp \
- th5s.cpp tlinks.cpp trefer.cpp ttypes.cpp tvlstr.cpp h5cpputil.cpp
+testhdf5_SOURCES=testhdf5.cpp dsets.cpp tattr.cpp tcompound.cpp \
+ tfile.cpp tfilter.cpp th5s.cpp tlinks.cpp trefer.cpp \
+ ttypes.cpp tvlstr.cpp h5cpputil.cpp
# Tell conclude.am that these are C++ tests.
CXX_API=yes