summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2014-04-12 02:47:07 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2014-04-12 02:47:07 (GMT)
commitf61bc97180e88c6081c7cc9a420b7e9540bfd1a0 (patch)
tree272d6803208c796132836d4fb22cebfa09f8da88 /c++/test/Makefile.am
parentadff7e81bd0013af6f2e468e1eb0b9622897ab20 (diff)
downloadhdf5-f61bc97180e88c6081c7cc9a420b7e9540bfd1a0.zip
hdf5-f61bc97180e88c6081c7cc9a420b7e9540bfd1a0.tar.gz
hdf5-f61bc97180e88c6081c7cc9a420b7e9540bfd1a0.tar.bz2
[svn-r25023] Description:
- Added wrappers to H5Object for H5Iget_name() to get object's name ssize_t getObjName(char *obj_name, size_t buf_size = 0) const; ssize_t getObjName(H5std_string& obj_name, size_t len = 0) const; H5std_string getObjName() const; - Added tests tobject.cpp - Added to various cleanup_* functions in tests to remove generated files - Added an overload H5I_type_t getHDFObjType() to get object's type (merge from trunk-24969) Platforms tested: Linux/ppc64 (ostrich) Linux/32 2.6 (jam) SunOS 5.11 (emu) with gmake
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index 6cef381..2717e9c 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -38,8 +38,8 @@ check_PROGRAMS=$(TEST_PROG)
LDADD=$(LIBH5TEST) $(LIBH5CPP) $(LIBHDF5)
testhdf5_SOURCES=testhdf5.cpp dsets.cpp tattr.cpp tcompound.cpp \
- tdspl.cpp tfile.cpp tfilter.cpp th5s.cpp tlinks.cpp trefer.cpp \
- ttypes.cpp tvlstr.cpp h5cpputil.cpp
+ tdspl.cpp tfile.cpp tfilter.cpp th5s.cpp tlinks.cpp tobject.cpp \
+ trefer.cpp ttypes.cpp tvlstr.cpp h5cpputil.cpp
# Tell conclude.am that these are C++ tests.
CXX_API=yes