summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
authorBinh-Minh Ribler <bmribler@hdfgroup.org>2014-03-30 16:15:11 (GMT)
committerBinh-Minh Ribler <bmribler@hdfgroup.org>2014-03-30 16:15:11 (GMT)
commitbe38074a2fc72d6040d280777cb9772bdf6c5587 (patch)
tree8a2f30063607ad5f28552f1b3bc1554b364c019b /c++/test/Makefile.am
parentd6cd6cabc2734d6548af4139ec912814174adb84 (diff)
downloadhdf5-be38074a2fc72d6040d280777cb9772bdf6c5587.zip
hdf5-be38074a2fc72d6040d280777cb9772bdf6c5587.tar.gz
hdf5-be38074a2fc72d6040d280777cb9772bdf6c5587.tar.bz2
[svn-r24925] Purpose: Fix HDFFV-7907
Description: Added transform property list functions // Constructor creates a dataset transform property list. DSetMemXferPropList(const char* expression); // Sets data transform expression. void setDataTransform(const char* expression) const; void setDataTransform(const H5std_string& expression) const; // Gets data transform expression. ssize_t getDataTransform(char* exp, size_t buf_size=0) const; H5std_string getDataTransform() const; Added test file tdspl.cpp. Platforms tested: Linux/ppc64 (ostrich) Linux/32 2.6 (jam) SunOS 5.11 (emu)
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index 3f62bda..74241f1 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -38,7 +38,7 @@ check_PROGRAMS=$(TEST_PROG)
LDADD=$(LIBH5TEST) $(LIBH5CPP) $(LIBHDF5)
testhdf5_SOURCES=testhdf5.cpp dsets.cpp tattr.cpp tcompound.cpp \
- tfile.cpp tfilter.cpp th5s.cpp tlinks.cpp trefer.cpp \
+ tdspl.cpp tfile.cpp tfilter.cpp th5s.cpp tlinks.cpp trefer.cpp \
ttypes.cpp tvlstr.cpp h5cpputil.cpp
# Tell conclude.am that these are C++ tests.