summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-28 23:23:46 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-28 23:23:46 (GMT)
commit11fabfd693a5970ab30ca4460f8ec5aef3227beb (patch)
tree0dcdffaf55e06069bc0b8676c44607edd54ab582 /c++/test/Makefile.am
parent5b4232e9d164434e422bdd72199f39507af984d8 (diff)
downloadhdf5-11fabfd693a5970ab30ca4460f8ec5aef3227beb.zip
hdf5-11fabfd693a5970ab30ca4460f8ec5aef3227beb.tar.gz
hdf5-11fabfd693a5970ab30ca4460f8ec5aef3227beb.tar.bz2
[svn-r10108] Purpose:
Bug fix Description: C++ tests would die with strange linking-type errors. Solution: C++ build needs to be static, too. Applied -static flags liberally in c++/src and c++/test directories. Platforms tested: sleipnir, heping
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index 34c1945..62dfb37 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -22,6 +22,9 @@ include $(top_srcdir)/config/commence.am
# Include src, test, and c++/src directories
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/c++/src
+# C++ libraries and tests are built statically
+AM_LDFLAGS=-static
+
# These are our main targets. They should be listed in the order to be
# executed, generally most specific tests to least specific tests.
TEST_PROG=dsets testhdf5