summaryrefslogtreecommitdiffstats
path: root/c++/test/Makefile.am
diff options
context:
space:
mode:
authorElena Pourmal <epourmal@hdfgroup.org>2013-11-03 01:21:23 (GMT)
committerElena Pourmal <epourmal@hdfgroup.org>2013-11-03 01:21:23 (GMT)
commit7aa4a180e48820e322067892214b9125279608b9 (patch)
tree2f1630569b1e9e6baab9d2e14afc660cb9f96acd /c++/test/Makefile.am
parent819b8099e24809cdb9c9e2e11078cffc0e754ace (diff)
downloadhdf5-7aa4a180e48820e322067892214b9125279608b9.zip
hdf5-7aa4a180e48820e322067892214b9125279608b9.tar.gz
hdf5-7aa4a180e48820e322067892214b9125279608b9.tar.bz2
[svn-r24400] Maintenance: When the libraries are built and tested in place, several files are left
behind by "make distclean" (see below); modified appropriate Makefile.am files and ran bin/reconfigure to create Makefile.in to fix the problem. Here is the list of the files "make disclean" doesn't remove: tools/h5dump/testfiles tools/h5repack/testfiles/h5diff_attr1.h5 tools/h5repack/testfiles/tfamily00000.h5 tools/h5repack/testfiles/tfamily00010.h5 tools/h5repack/testfiles/tfamily00002.h5 tools/h5repack/testfiles/tfamily00004.h5 tools/h5repack/testfiles/tfamily00006.h5 tools/h5repack/testfiles/tfamily00008.h5 tools/h5repack/testfiles/tfamily00001.h5 tools/h5repack/testfiles/tfamily00003.h5 tools/h5repack/testfiles/tfamily00005.h5 tools/h5repack/testfiles/tfamily00007.h5 tools/h5repack/testfiles/tfamily00009.h5 tools/h5jam/testfiles/h5jam-ub-nohdf5.txt.err-sav tools/h5jam/testfiles/h5jam-help.txt.err-sav tools/h5jam/testfiles/h5unjam-help.txt.err-sav tools/h5jam/testfiles/h5jam-ub-nohdf5.txt.out-sav tools/h5jam/testfiles/h5jam-help.txt.out-sav tools/h5jam/testfiles/h5unjam-help.txt.out-sav hl/fortran/test/dsetf5.h5 c++/test/tattr_multi.h5 c++/test/tattr_scalar.h5 c++/test/tfattrs.h5 c++/test/tattr_basic.h5 c++/test/tattr_compound.h5 c++/test/tattr_dtype.h5 Tested on jam and emu in place and using srcdir with the svn stat command. This fix doesn't address two problems: tool/h5dump/testfiles directory is not removed by "make distclean" and it should be tools/misc/testfiles directory is removed by "make distclean" and it shouldn't be
Diffstat (limited to 'c++/test/Makefile.am')
-rw-r--r--c++/test/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/c++/test/Makefile.am b/c++/test/Makefile.am
index 687f0ca..3f62bda 100644
--- a/c++/test/Makefile.am
+++ b/c++/test/Makefile.am
@@ -51,5 +51,8 @@ mostlyclean-local:
@if test -d ii_files; then \
$(RM) -rf ii_files; \
fi
+# Temporary files
+CHECK_CLEANFILES+=tattr_multi.h5 tfattrs.h5 tattr_scalar.h5 tattr_compound.h5 \
+ tattr_dtype.h5 tattr_basic.h5
include $(top_srcdir)/config/conclude.am