summaryrefslogtreecommitdiffstats
path: root/config/cmake/LIBAEC/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2024-01-04 18:06:36 (GMT)
committerGitHub <noreply@github.com>2024-01-04 18:06:36 (GMT)
commita00d62f77a715b0b4b862a594d1d85f4a0e5296c (patch)
treea71df5a1d896a4db7afa61cf3632768ae960c4fd /config/cmake/LIBAEC/CMakeLists.txt
parentde3ee47a44ffa7876c1e823eef6045f7fde8e165 (diff)
downloadhdf5-a00d62f77a715b0b4b862a594d1d85f4a0e5296c.zip
hdf5-a00d62f77a715b0b4b862a594d1d85f4a0e5296c.tar.gz
hdf5-a00d62f77a715b0b4b862a594d1d85f4a0e5296c.tar.bz2
Use props for includes and remove global includes (#3921)
Diffstat (limited to 'config/cmake/LIBAEC/CMakeLists.txt')
-rw-r--r--config/cmake/LIBAEC/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/config/cmake/LIBAEC/CMakeLists.txt b/config/cmake/LIBAEC/CMakeLists.txt
index a819587..e118438 100644
--- a/config/cmake/LIBAEC/CMakeLists.txt
+++ b/config/cmake/LIBAEC/CMakeLists.txt
@@ -146,7 +146,9 @@ configure_file (${LIBAEC_RESOURCES_DIR}/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/
#-----------------------------------------------------------------------------
# All libs/tests/examples need the main include directories
#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (${LIBAEC_BINARY_DIR} ${LIBAEC_SOURCE_DIR}/src ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
+set_directory_properties(PROPERTIES INCLUDE_DIRECTORIES
+ "${LIBAEC_BINARY_DIR};${LIBAEC_SOURCE_DIR}/src;${CMAKE_RUNTIME_OUTPUT_DIRECTORY}"
+)
#-----------------------------------------------------------------------------
# Define LIBAEC Library