summaryrefslogtreecommitdiffstats
path: root/config/cmake/LIBAEC/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2024-01-09 17:15:46 (GMT)
committerGitHub <noreply@github.com>2024-01-09 17:15:46 (GMT)
commitc3180334e0af1150812f903dd5df34d392259072 (patch)
treec7126e26a29de16f88a2f5cc62f95daac2cf391e /config/cmake/LIBAEC/CMakeLists.txt
parentc0d6d9bb220bf995a268367cca88dc4febbacf99 (diff)
downloadhdf5-c3180334e0af1150812f903dd5df34d392259072.zip
hdf5-c3180334e0af1150812f903dd5df34d392259072.tar.gz
hdf5-c3180334e0af1150812f903dd5df34d392259072.tar.bz2
CMake compression and directory includes from develop (#3933)
* Merge CMake dir props and compression changes from develop * Remove unused include
Diffstat (limited to 'config/cmake/LIBAEC/CMakeLists.txt')
-rw-r--r--config/cmake/LIBAEC/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/config/cmake/LIBAEC/CMakeLists.txt b/config/cmake/LIBAEC/CMakeLists.txt
index a819587..e118438 100644
--- a/config/cmake/LIBAEC/CMakeLists.txt
+++ b/config/cmake/LIBAEC/CMakeLists.txt
@@ -146,7 +146,9 @@ configure_file (${LIBAEC_RESOURCES_DIR}/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/
#-----------------------------------------------------------------------------
# All libs/tests/examples need the main include directories
#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (${LIBAEC_BINARY_DIR} ${LIBAEC_SOURCE_DIR}/src ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
+set_directory_properties(PROPERTIES INCLUDE_DIRECTORIES
+ "${LIBAEC_BINARY_DIR};${LIBAEC_SOURCE_DIR}/src;${CMAKE_RUNTIME_OUTPUT_DIRECTORY}"
+)
#-----------------------------------------------------------------------------
# Define LIBAEC Library