summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2013-10-18 20:03:47 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2013-10-18 20:03:47 (GMT)
commit9729a518b49a2217307c3c7ce9b33b064fc83147 (patch)
tree28b22bf7d1972b4a537bcec377778147c976420c /configure.ac
parent1bc858b1b889ae2d0eeca463646592d195db8c94 (diff)
downloadhdf5-9729a518b49a2217307c3c7ce9b33b064fc83147.zip
hdf5-9729a518b49a2217307c3c7ce9b33b064fc83147.tar.gz
hdf5-9729a518b49a2217307c3c7ce9b33b064fc83147.tar.bz2
[svn-r24332] Bring revision #24330 from revise_chunks. h5committested.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6c1a0a8..d2623d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1467,7 +1467,7 @@ case "$host_cpu-$host_vendor-$host_os" in
;;
esac
-## Need to add the AM_ and H5_ into CPFLAGS/CPPFLAGS to make them visible
+## Need to add the AM_ and H5_ into CFLAGS/CPPFLAGS to make them visible
## for configure checks.
## Note: Both will be restored by the end of configure.
CPPFLAGS="$H5_CPPFLAGS $AM_CPPFLAGS $CPPFLAGS"
@@ -3052,6 +3052,27 @@ if test "X$default_vfd" = "Xyes"; then
fi
## ----------------------------------------------------------------------
+## Enable custom plugin default path for library. It requires SHARED support.
+##
+AC_MSG_CHECKING([for Custom Plugin Default Path definition])
+AC_ARG_WITH([default-plugin],
+ [AS_HELP_STRING([--with-default-plugin=location],
+ [Specify default location for plugins
+ [default="/usr/local/hdf5/lib/plugin"]])],,
+ withval="/usr/local/hdf5/lib/plugin")
+
+if test "X$withval" = "X"; then
+ AC_MSG_RESULT([default])
+ default_plugin="/usr/local/hdf5/lib/plugin"
+else
+ AC_MSG_RESULT([$withval])
+ default_plugin=$withval
+fi
+
+AC_DEFINE_UNQUOTED([DEFAULT_PLUGIN], ["$default_plugin"],
+ [Define the default plugins path to compile])
+
+## ----------------------------------------------------------------------
## Check if Direct I/O driver is enabled by --enable-direct-vfd
##
@@ -4518,6 +4539,7 @@ AC_CONFIG_FILES([src/libhdf5.settings
tools/h5jam/testh5jam.sh
tools/h5repack/Makefile
tools/h5repack/h5repack.sh
+ tools/h5repack/h5repack_plugin.sh
tools/h5ls/Makefile
tools/h5copy/Makefile
tools/h5copy/testh5copy.sh