summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-11-09 17:22:14 (GMT)
committerGitHub <noreply@github.com>2022-11-09 17:22:14 (GMT)
commit0f30852242d906cb21d0246b3e68527f608d4d84 (patch)
tree4b1701d9155b315cad7ee1ecde250e816aedbd42 /configure.ac
parent2025d047e212b5c804ec788fe3bbbf87a93b512b (diff)
downloadhdf5-0f30852242d906cb21d0246b3e68527f608d4d84.zip
hdf5-0f30852242d906cb21d0246b3e68527f608d4d84.tar.gz
hdf5-0f30852242d906cb21d0246b3e68527f608d4d84.tar.bz2
Removes dmalloc support (#2239)
This has not been used to debug the library in a very long time. Most developers use valgrind, -fsanitize=address, or some other memory checker instead of this library. This removes: * dmalloc.h include from H5private.h * --with-dmalloc= Autotools configure option * HDF5_ENABLE_USING_DMALLOC CMake option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac77
1 files changed, 0 insertions, 77 deletions
diff --git a/configure.ac b/configure.ac
index fed9ca7..c12c0f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1537,83 +1537,6 @@ AC_ARG_WITH([fnord],
])
## ----------------------------------------------------------------------
-## Is dmalloc (debug malloc library) requested? It has a header file
-## `dmalloc.h' and a library `-ldmalloc' and their locations might be
-## specified with the `--with-dmalloc' command-line switch. The value
-## is an include path and/or a library path. If the library path is
-## specified then it must be preceded by a comma.
-##
-AC_SUBST([HAVE_DMALLOC])
-
-## Default is not present
-HAVE_DMALLOC=no
-
-AC_ARG_WITH([dmalloc],
- [AS_HELP_STRING([--with-dmalloc=DIR],
- [Use dmalloc memory debugging aid [default=no]])],,
- [withval=no])
-
-case "X-$withval" in
- X-yes)
- HAVE_DMALLOC="yes"
- AC_CHECK_HEADERS([dmalloc.h],, [unset HAVE_DMALLOC])
- if test "x$HAVE_DMALLOC" = "xyes"; then
- AC_CHECK_LIB([dmalloc], [dmalloc_shutdown],, [unset HAVE_DMALLOC])
- fi
- if test -z "$HAVE_DMALLOC" -a -n "$HDF5_CONFIG_ABORT"; then
- AC_MSG_ERROR([couldn't find dmalloc library])
- fi
- ;;
- X-|X-no|X-none)
- HAVE_DMALLOC="no"
- AC_MSG_CHECKING([for dmalloc library])
- AC_MSG_RESULT([suppressed])
- ;;
- *)
- HAVE_DMALLOC="yes"
- case "$withval" in
- *,*)
- dmalloc_inc="`echo $withval |cut -f1 -d,`"
- dmalloc_lib="`echo $withval |cut -f2 -d, -s`"
- ;;
- *)
- if test -n "$withval"; then
- dmalloc_inc="$withval/include"
- dmalloc_lib="$withval/lib"
- fi
- ;;
- esac
-
- saved_CPPFLAGS="$CPPFLAGS"
- saved_AM_CPPFLAGS="$AM_CPPFLAGS"
- saved_LDFLAGS="$LDFLAGS"
- saved_AM_LDFLAGS="$AM_LDFLAGS"
-
- if test -n "$dmalloc_inc"; then
- CPPFLAGS="$CPPFLAGS -I$dmalloc_inc"
- AM_CPPFLAGS="$AM_CPPFLAGS -I$dmalloc_inc"
- fi
-
- AC_CHECK_HEADERS([dmalloc.h],,[CPPFLAGS="$saved_CPPFLAGS"; AM_CPPFLAGS="$saved_AM_CPPFLAGS"] [unset HAVE_DMALLOC])
-
- if test "x$HAVE_DMALLOC" = "xyes"; then
- if test -n "$dmalloc_lib"; then
- LDFLAGS="$LDFLAGS -L$dmalloc_lib"
- AM_LDFLAGS="$AM_LDFLAGS -L$dmalloc_lib"
- fi
-
- AC_CHECK_LIB([dmalloc], [dmalloc_shutdown],, [LDFLAGS="$saved_LDFLAGS"; AM_LDFLAGS="$saved_AM_LDFLAGS"; unset HAVE_DMALLOC])
- fi
-
- if test -z "$HAVE_DMALLOC" -a -n "$HDF5_CONFIG_ABORT"; then
- AC_MSG_ERROR([couldn't find dmalloc library])
- fi
- ;;
-esac
-
-
-
-## ----------------------------------------------------------------------
## Make the external filters list available to *.in files
## At this point it's unset (no external filters by default) but it
## will be filled in during the deflate (zlib) and szip processing