summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-12-17 03:56:07 (GMT)
committerGitHub <noreply@github.com>2022-12-17 03:56:07 (GMT)
commit149b8e9769887c5b23400b526dc10463f88f2c3e (patch)
treec6eaae15688e7fe8be18664ec8f0e8c31f8ec15d /configure.ac
parent8102fa8c972bdc0d8fd8f3dae604e070893150d6 (diff)
downloadhdf5-149b8e9769887c5b23400b526dc10463f88f2c3e.zip
hdf5-149b8e9769887c5b23400b526dc10463f88f2c3e.tar.gz
hdf5-149b8e9769887c5b23400b526dc10463f88f2c3e.tar.bz2
Disable hl tools by default (#2313)
* Disable hl tools by default * identify the tools * Only GIF tools are depecated * Add new option * Update autotools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7d1129..5f62140 100644
--- a/configure.ac
+++ b/configure.ac
@@ -833,6 +833,7 @@ AC_LANG_POP(C++)
## library is disabled.
AC_SUBST([HDF5_HL])
AC_SUBST([HDF5_HL_TOOLS])
+AC_SUBST([HDF5_HL_GIF_TOOLS])
## The high-level library and high-level tools are enabled unless the build mode
## is clean.
@@ -888,6 +889,21 @@ else
AC_MSG_RESULT([no])
fi
+AC_MSG_CHECKING([if the high-level GIF tools are enabled])
+AC_ARG_ENABLE([hltools],
+ [AS_HELP_STRING([--enable-hlgiftools],
+ [Enable the high-level GIF tools.
+ [default=no]
+ ])],
+ [HDF5_HL_GIF_TOOLS=$enableval])
+
+if test "X${HDF5_GIF_HL}" = "Xyes" -a "X-$HDF5_HL_TOOLS" = "X-yes" -a "X-$HDF5_HL_GIF_TOOLS" = "X-yes"; then
+ AC_MSG_RESULT([yes])
+ HL_GIF_TOOLS="tools"
+else
+ AC_MSG_RESULT([no])
+fi
+
## ----------------------------------------------------------------------
## Enable new references for dimension scales
@@ -3907,6 +3923,7 @@ AM_CONDITIONAL([BUILD_TESTS_CONDITIONAL], [test "X$HDF5_TESTS" = "Xyes"])
AM_CONDITIONAL([BUILD_TESTS_PARALLEL_CONDITIONAL], [test -n "$TESTPARALLEL"])
AM_CONDITIONAL([BUILD_TOOLS_CONDITIONAL], [test "X$HDF5_TOOLS" = "Xyes"])
AM_CONDITIONAL([BUILD_TOOLS_HL_CONDITIONAL], [test "X$HDF5_HL_TOOLS" = "Xyes"])
+AM_CONDITIONAL([BUILD_TOOLS_HL_GIF_CONDITIONAL], [test "X$HDF5_HL_GIF_TOOLS" = "Xyes"])
AM_CONDITIONAL([BUILD_DOXYGEN_CONDITIONAL], [test "X$HDF5_DOXYGEN" = "Xyes"])
## ----------------------------------------------------------------------