summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2020-03-19 20:09:55 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2020-03-19 20:09:55 (GMT)
commit1cc2b65b1f745d9b7d770504fb3def73ba8346c1 (patch)
tree15716b78b101cfb1a5ce442493f18f00d159516f /configure.ac
parent27e14f31f7dce3765d6c3ce51b6ff4e700a22e19 (diff)
downloadhdf5-1cc2b65b1f745d9b7d770504fb3def73ba8346c1.zip
hdf5-1cc2b65b1f745d9b7d770504fb3def73ba8346c1.tar.gz
hdf5-1cc2b65b1f745d9b7d770504fb3def73ba8346c1.tar.bz2
Fixes for test failures with --disable-tests --disable-tools options.
Don't test ph5diff if tests are disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e20f46b..2254e19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2046,8 +2046,10 @@ esac
AC_SUBST([ADD_PARALLEL_FILES]) ADD_PARALLEL_FILES="no"
if test -n "$PARALLEL"; then
- ## The 'testpar' directory should participate in the build
- TESTPARALLEL=testpar
+ if test "X$HDF5_TESTS" = "Xyes"; then
+ ## The 'testpar' directory should participate in the build
+ TESTPARALLEL=testpar
+ fi
## We are building a parallel library
AC_DEFINE([HAVE_PARALLEL], [1], [Define if we have parallel support])
@@ -3013,7 +3015,7 @@ LDFLAGS="$saved_user_LDFLAGS"
## need to be compiled
AM_CONDITIONAL([BUILD_CXX_CONDITIONAL], [test "X$HDF_CXX" = "Xyes"])
-AM_CONDITIONAL([BUILD_PARALLEL_CONDITIONAL], [test -n "$TESTPARALLEL"])
+AM_CONDITIONAL([BUILD_PARALLEL_CONDITIONAL], [test -n "$PARALLEL"])
AM_CONDITIONAL([BUILD_FORTRAN_CONDITIONAL], [test "X$HDF_FORTRAN" = "Xyes"])
AM_CONDITIONAL([BUILD_HDF5_HL_CONDITIONAL], [test "X$HDF5_HL" = "Xyes"])
AM_CONDITIONAL([BUILD_TESTS_CONDITIONAL], [test "X$HDF5_TESTS" = "Xyes"])