summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2023-07-13 17:19:02 (GMT)
committerGitHub <noreply@github.com>2023-07-13 17:19:02 (GMT)
commit26059fc7abd51827d0e7a798fac1cfa7461db7d3 (patch)
treed429feaa8d22f72f7415330c895d2562f405e46d /configure.ac
parentb77d5bacea7f004153b2752a9cb17d26ae975cf9 (diff)
downloadhdf5-26059fc7abd51827d0e7a798fac1cfa7461db7d3.zip
hdf5-26059fc7abd51827d0e7a798fac1cfa7461db7d3.tar.gz
hdf5-26059fc7abd51827d0e7a798fac1cfa7461db7d3.tar.bz2
Subfiling VFD source cleanup (#3241)
* Subfiling VFD source cleanup Modularize Subfiling CMake code into separate CMakeLists.txt file Update Mercury util code to latest version and update Copyright Generate mercury_util_config.h header file instead of using pre-generated file Remove unnecessary Mercury functionality Fix minor warning in Subfiling VFD code * Remove Mercury headers from Autotools publicly-distributed header list
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fe9072..d669bea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3088,6 +3088,23 @@ if test "X$SUBFILING_VFD" = "Xyes"; then
AC_SEARCH_LIBS([shm_open], [rt])
AC_CHECK_LIB([pthread], [pthread_self],[], [echo "Error: Required library pthread not found." && exit 1])
+ # Perform various checks for Mercury util code
+ AC_CHECK_DECL([PTHREAD_MUTEX_ADAPTIVE_NP],
+ [AC_DEFINE([HAVE_PTHREAD_MUTEX_ADAPTIVE_NP], [1],
+ [Define if has PTHREAD_MUTEX_ADAPTIVE_NP])],
+ [],
+ [[#include <pthread.h>]])
+ AC_CHECK_DECL([pthread_condattr_setclock],
+ [AC_DEFINE([HAVE_PTHREAD_CONDATTR_SETCLOCK], [1],
+ [Define if has pthread_condattr_setclock()])],
+ [],
+ [[#include <pthread.h>]])
+ AC_CHECK_DECL([CLOCK_MONOTONIC_COARSE],
+ [AC_DEFINE([HAVE_CLOCK_MONOTONIC_COARSE], [1],
+ [Define if has CLOCK_MONOTONIC_COARSE])],
+ [],
+ [[#include <time.h>]])
+
else
AC_MSG_RESULT([no])
fi