summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-07-01 02:50:42 (GMT)
committerGitHub <noreply@github.com>2022-07-01 02:50:42 (GMT)
commit3ed53d17fb018c0415be2d668c6765217deff16f (patch)
tree65a8ac799d1510f64311016efb8e3130b28ea47a /configure.ac
parent41526f68f3482f2b3a7aa581288bc86e9c6dcb43 (diff)
downloadhdf5-3ed53d17fb018c0415be2d668c6765217deff16f.zip
hdf5-3ed53d17fb018c0415be2d668c6765217deff16f.tar.gz
hdf5-3ed53d17fb018c0415be2d668c6765217deff16f.tar.bz2
Removes workaround for platforms that lack C99 stuct initializers (#1842)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 7c9d990..d493873 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2140,21 +2140,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]],[[int __attribute__((unused)) x]])],
AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no])])
-AC_MSG_CHECKING([for C99 designated initialization support])
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
- typedef struct {
- int x;
- union {
- int i;
- double d;
- } u;
- } di_struct_t;
- di_struct_t x = {0, { .d = 0.0}}; ]])],
- [AC_DEFINE([HAVE_C99_DESIGNATED_INITIALIZER], [1],
- [Define if the compiler understands C99 designated initialization of structs and unions])
- AC_MSG_RESULT([yes])],
- [AC_MSG_RESULT([no])])
-
## ----------------------------------------------------------------------
## Remove old ways of determining debug/production build.
## These were used in 1.8.x and earlier. We should probably keep these checks