summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2016-02-26 23:38:44 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2016-02-26 23:38:44 (GMT)
commit594189a67300329207f21198a2606175acc4b89e (patch)
treed6cefd95bea03b7fc9fbae6f0b100fef7f7ddd4b /configure.ac
parent39c629fc97d29c030675e533befad037018c17e9 (diff)
downloadhdf5-594189a67300329207f21198a2606175acc4b89e.zip
hdf5-594189a67300329207f21198a2606175acc4b89e.tar.gz
hdf5-594189a67300329207f21198a2606175acc4b89e.tar.bz2
[svn-r29218] Revert of r28909 and r28914
This commented out the memory allocation sanity checker in alpha1. The feature has been restored for alpha2. The H5B package was also removed from the "all" list of package- specific debugging output since it slows down the library so much. This equivalent to r29099 in revise_chunks but was done manually since that change comes after major configure.ac rework. Tested on: jam
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 25 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 52c77e5..f79b485 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1866,7 +1866,7 @@ if test "X-$DEBUG_PKG" = X- ; then
fi
AC_SUBST([DEBUG_PKG])
-all_packages="ac,b,b2,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
+all_packages="ac,b2,d,e,f,g,hg,hl,i,mf,mm,o,p,s,t,v,z"
case "X-$DEBUG_PKG" in
X-yes)
DEBUG_PKG="d,e,f,g,hg,i,mm,o,p,s,t,v,z"
@@ -2071,30 +2071,30 @@ esac
## Check if they would like to enable the internal memory allocation sanity
## checking code.
##
-##AC_SUBST([MEMORYALLOCSANITYCHECK])
-##AC_MSG_CHECKING([whether internal memory allocation sanity checking is used])
-##AC_ARG_ENABLE([memory-alloc-sanity-check],
-## [AS_HELP_STRING([--enable-memory-alloc-sanity-check],
-## [Enable this option to turn on internal memory
-## allocation sanity checking. This could cause
-## more memory use and somewhat slower allocation.
-## This option is orthogonal to the
-## --enable-using-memchecker option.
-## Default=no.])],
-## [MEMORYALLOCSANITYCHECK=$enableval])
-##
-##case "X-$MEMORYALLOCSANITYCHECK" in
-## X-yes)
-## MEMORYALLOCSANITYCHECK=yes
-## AC_MSG_RESULT([yes])
-## AC_DEFINE([MEMORY_ALLOC_SANITY_CHECK], [1],
-## [Define to enable internal memory allocation sanity checking.])
-## ;;
-## *)
-## MEMORYALLOCSANITYCHECK=no
-## AC_MSG_RESULT([no])
-## ;;
-##esac
+AC_SUBST([MEMORYALLOCSANITYCHECK])
+AC_MSG_CHECKING([whether internal memory allocation sanity checking is used])
+AC_ARG_ENABLE([memory-alloc-sanity-check],
+ [AS_HELP_STRING([--enable-memory-alloc-sanity-check],
+ [Enable this option to turn on internal memory
+ allocation sanity checking. This could cause
+ more memory use and somewhat slower allocation.
+ This option is orthogonal to the
+ --enable-using-memchecker option.
+ Default=no.])],
+ [MEMORYALLOCSANITYCHECK=$enableval])
+
+case "X-$MEMORYALLOCSANITYCHECK" in
+ X-yes)
+ MEMORYALLOCSANITYCHECK=yes
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([MEMORY_ALLOC_SANITY_CHECK], [1],
+ [Define to enable internal memory allocation sanity checking.])
+ ;;
+ *)
+ MEMORYALLOCSANITYCHECK=no
+ AC_MSG_RESULT([no])
+ ;;
+esac
## Checkpoint the cache
AC_CACHE_SAVE