summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2023-10-08 01:16:30 (GMT)
committerGitHub <noreply@github.com>2023-10-08 01:16:30 (GMT)
commit6edd9a0aab0d80b64b6038ba2942315cdcc4d0db (patch)
tree1af0eb10740c59c87e14d8b11d32ae8f61894c48 /configure.ac
parent07347cc5dd62b75587eff7db30c6420de4b9b73f (diff)
downloadhdf5-6edd9a0aab0d80b64b6038ba2942315cdcc4d0db.zip
hdf5-6edd9a0aab0d80b64b6038ba2942315cdcc4d0db.tar.gz
hdf5-6edd9a0aab0d80b64b6038ba2942315cdcc4d0db.tar.bz2
Drop MPI-2 support (#3643)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 37252d9..9e823ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2654,6 +2654,20 @@ if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
fi
fi
+# Requires MPI standard 3.0 and greater
+if test "X${enable_parallel}" = "Xyes"; then
+ AC_MSG_CHECKING([whether MPI meets the minimum 3.0 standard])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <mpi.h>
+ #if MPI_VERSION < 3
+ #error, found MPI_VERSION < 3
+ #endif]])],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])
+ AC_MSG_ERROR([HDF5 requires MPI standard 3.0 or greater])]
+ )
+fi
+
AC_MSG_CHECKING([for parallel support files])
case "X-$enable_parallel" in
X-|X-no|X-none)