summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-27 20:11:12 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-27 20:11:12 (GMT)
commit79f59eaf4dcf7a958881936d645c5c1a47484cd9 (patch)
tree896b53fe3f6f6d880f9d05847938f13d05b6c76a /configure.ac
parentf7386e173c6996c1d1b6b560dd6d12d3e35d8402 (diff)
downloadhdf5-79f59eaf4dcf7a958881936d645c5c1a47484cd9.zip
hdf5-79f59eaf4dcf7a958881936d645c5c1a47484cd9.tar.gz
hdf5-79f59eaf4dcf7a958881936d645c5c1a47484cd9.tar.bz2
[svn-r26623] Description:
Bring r26513 from autotools_rework branch to trunk: Remove the LDOUBLE_TO_LLONG_ACCURATE macro/define, it's working around bugs in older SGI, HP/UX, MacOSX and Windows .NET 2003 compilers. Tested on: Linux/32 2.6.18 (jam) w/serial & parallel (Daily tested on branch for 2+ days)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac64
1 files changed, 0 insertions, 64 deletions
diff --git a/configure.ac b/configure.ac
index e285d5e..91bad1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2702,70 +2702,6 @@ fi
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert
-## 'long double' to '(unsigned) long long' values. (This flag should be set for
-## all machines, except for Mac OS 10.4 and SGI IRIX64 6.5. When the bit sequence
-## of long double is 0x4351ccf385ebc8a0bfcc2a3c..., the values of (unsigned)long long
-## start to go wrong on these two machines. Adjusting it higher to
-## 0x4351ccf385ebc8a0dfcc... or 0x4351ccf385ebc8a0ffcc... will make the converted
-## values wildly wrong. This test detects this wrong behavior and disable the test.
-##
-AC_MSG_CHECKING([if correctly converting long double to (unsigned) long long values])
-
-if test ${ac_cv_sizeof_long_double} = 0; then
- hdf5_cv_ldouble_to_llong_accurate=${hdf5_cv_ldouble_to_llong_accurate=no}
-else
- AC_CACHE_VAL([hdf5_cv_ldouble_to_llong_accurate],
- [AC_TRY_RUN([
- int main(void)
- {
- long double ld = 20041683600089727.779961L;
- long long ll;
- unsigned long long ull;
- unsigned char s[16];
- int ret = 0;
-
- if(sizeof(long double) == 16) {
- /*make sure the long double type is the same as the failing type
- *which has 16 bytes in size and 11 bits of exponent. If it is,
- *the bit sequence should be like below. It's not
- *a decent way to check but this info isn't available. */
- memcpy(s, &ld, 16);
- if(s[0]==0x43 && s[1]==0x51 && s[2]==0xcc && s[3]==0xf3 &&
- s[4]==0x85 && s[5]==0xeb && s[6]==0xc8 && s[7]==0xa0 &&
- s[8]==0xbf && s[9]==0xcc && s[10]==0x2a && s[11]==0x3c) {
-
- /*slightly adjust the bit sequence (s[8]=0xdf). The converted
- *values will go wild on Mac OS 10.4 and IRIX64 6.5.*/
- s[0]=0x43; s[1]=0x51; s[2]=0xcc; s[3]=0xf3;
- s[4]=0x85; s[5]=0xeb; s[6]=0xc8; s[7]=0xa0;
- s[8]=0xdf; s[9]=0xcc; s[10]=0x2a; s[11]=0x3c;
- s[12]=0x3d; s[13]=0x85; s[14]=0x56; s[15]=0x20;
-
- memcpy(&ld, s, 16);
- ll = (long long)ld;
- ull = (unsigned long long)ld;
-
- if(ll != 20041683600089728 || ull != 20041683600089728)
- ret = 1;
- }
- }
- done:
- exit(ret);
- }
- ], [hdf5_cv_ldouble_to_llong_accurate=yes], [hdf5_cv_ldouble_to_llong_accurate=no],)])
-fi
-
-if test ${hdf5_cv_ldouble_to_llong_accurate} = "yes"; then
- AC_DEFINE([LDOUBLE_TO_LLONG_ACCURATE], [1],
- [Define if your system can convert long double to (unsigned) long long values correctly.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-
-## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can accurately convert
## '(unsigned) long long' to 'long double' values. (This flag should be set for
## all machines, except for Mac OS 10.4, when the bit sequences are 003fff...,
## 007fff..., 00ffff..., 01ffff..., ..., 7fffff..., the converted values are twice