summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorlrknox <lrknox>2017-08-25 20:10:42 (GMT)
committerlrknox <lrknox>2017-08-25 20:10:42 (GMT)
commit7f758f2eea5c918a9100e6e7e6e0744a85e4c571 (patch)
tree49e9f344d5ad4af560d895bd698fdac35c246155 /configure.ac
parent1115133e11e43c45f5f20d74ca4bae76815c63d3 (diff)
parent23a702e7bad93fc4f14eab07678c75d276e2d0ad (diff)
downloadhdf5-7f758f2eea5c918a9100e6e7e6e0744a85e4c571.zip
hdf5-7f758f2eea5c918a9100e6e7e6e0744a85e4c571.tar.gz
hdf5-7f758f2eea5c918a9100e6e7e6e0744a85e4c571.tar.bz2
Merge branch '1.8/master' of https://bitbucket.hdfgroup.org/scm/hdffv/hdf5 into hdf5_1_8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c6d5b5a..e5590bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -846,10 +846,16 @@ case $host_os in
;;
esac
+## -----------
+## if `uname` is not CYGWIN, save that information to pass to Makefiles
+## to disable building and testing plugins.
+AC_SUBST([UNAME_CYGWIN]) UNAME_CYGWIN="no"
+
## Windows
case "`uname`" in
CYGWIN*)
AC_CHECK_HEADERS([io.h sys/timeb.h])
+ UNAME_CYGWIN="yes"
;;
MINGW*)
AC_CHECK_HEADERS([io.h winsock2.h sys/timeb.h])
@@ -859,6 +865,7 @@ case "`uname`" in
AC_CHECK_HEADERS([io.h winsock2.h sys/timeb.h])
;;
esac
+AM_CONDITIONAL([NOT_UNAME_CYGWIN], [test "X$UNAME_CYGWIN" = "Xno"])
## ----------------------------------------------------------------------
## Some platforms require that all symbols are resolved when a library
@@ -1715,7 +1722,7 @@ AC_ARG_ENABLE([debug],
])],
[DEBUG_PKG=$enableval])
-## Default to no if producton is enabled
+## Default to no if production is enabled
if test "X-$DEBUG_PKG" = X- ; then
if test "$enable_production" = yes ; then
DEBUG_PKG=no