summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2024-01-03 16:55:17 (GMT)
committerGitHub <noreply@github.com>2024-01-03 16:55:17 (GMT)
commit8f1a93f1a208055c9b872a06be28a20e72f8f488 (patch)
tree4791557ccb219f56111fa52a96462d319d1e4473 /configure.ac
parent812be1a3bdbc2fca620f85b3d0dc2f7216a9d463 (diff)
downloadhdf5-8f1a93f1a208055c9b872a06be28a20e72f8f488.zip
hdf5-8f1a93f1a208055c9b872a06be28a20e72f8f488.tar.gz
hdf5-8f1a93f1a208055c9b872a06be28a20e72f8f488.tar.bz2
New Fortran Examples added (#3916)
* added subfiling example * Added filtered writes with no selection example
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 650ee1d..e594ccc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -546,6 +546,17 @@ AC_CHECK_SIZEOF([float])
AC_CHECK_SIZEOF([double])
AC_CHECK_SIZEOF([long double])
+## HDF5 version from the first line of the README.md file.
+H5_VERSION="`cut -d' ' -f3 $srcdir/README.md | head -1`"
+AC_SUBST([H5_VERSION])
+
+VERS_MAJOR=`echo $H5_VERSION | cut -d. -f1`
+VERS_MINOR=`echo $H5_VERSION | cut -d. -f2`
+VERS_RELEASE=`echo $H5_VERSION | cut -d. -f3`
+AC_DEFINE_UNQUOTED([VERS_MAJOR], $VERS_MAJOR, [Define major library version])
+AC_DEFINE_UNQUOTED([VERS_MINOR], $VERS_MINOR, [Define minor library version])
+AC_DEFINE_UNQUOTED([VERS_RELEASE], $VERS_RELEASE, [Define release library version])
+
## ----------------------------------------------------------------------
## Check if the Fortran interface should be enabled
##
@@ -3672,10 +3683,6 @@ fi
## and installed with the libraries (used to generate libhdf5.settings).
##
-## HDF5 version from the first line of the README.md file.
-H5_VERSION="`cut -d' ' -f3 $srcdir/README.md | head -1`"
-AC_SUBST([H5_VERSION])
-
## Configuration date
AC_SUBST([CONFIG_DATE]) CONFIG_DATE="`date`"