summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2014-08-11 14:13:42 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2014-08-11 14:13:42 (GMT)
commit8fc11e6bc86da07802f3d647396eba691cfae566 (patch)
tree8bef84d52d9e83973bb006243defcccab2b8bfe3 /configure.ac
parent53e7d88a5fb63104240bcebdcf1ab03c294b1809 (diff)
downloadhdf5-8fc11e6bc86da07802f3d647396eba691cfae566.zip
hdf5-8fc11e6bc86da07802f3d647396eba691cfae566.tar.gz
hdf5-8fc11e6bc86da07802f3d647396eba691cfae566.tar.bz2
[svn-r25525] brought revision 25477 from the trunk.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec1233a..8ada98b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -586,6 +586,8 @@ AM_CONDITIONAL([FORTRAN_HAVE_STORAGE_SIZE], [test "X$HAVE_STORAGE_SIZE" = "Xyes"
AM_CONDITIONAL([FORTRAN_2003_CONDITIONAL_F], [test "X$HAVE_FORTRAN_2003" = "Xyes"])
AM_CONDITIONAL([FORTRAN_DEFAULT_REALisDBLE_F], [test "X$FORTRAN_DEFAULT_REALisDBLE" = "Xyes"])
+
+
## ----------------------------------------------------------------------
## Check if they would like the C++ interface compiled
##
@@ -4173,10 +4175,17 @@ if test "X$HDF5_HL" = "Xyes"; then
HL="hl"
AC_DEFINE([INCLUDE_HL], [1],
[Define if HDF5's high-level library headers should be included in hdf5.h])
+
+## Check if Fortran's default real is double precision. If it is and HL is being built then configure
+## should fail due to bug HDFFV-889.
+ if test "X$FORTRAN_DEFAULT_REALisDBLE" = "Xyes"; then
+ AC_MSG_ERROR([Fortran high-level routines are not supported when the default REAL is DOUBLE PRECISION, use configure option --disable-hl.])
+ fi
else
echo "no"
fi
+
## ----------------------------------------------------------------------
## Some programs shouldn't be built by default (e.g., programs to generate
## data files used by tests, some optional tests).