summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2015-09-15 20:38:57 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2015-09-15 20:38:57 (GMT)
commit9af344117c2d41886da1f54d3f5cff4091c4a943 (patch)
tree9dcb6bf61c2fbc5634b69f554690bb740b8decbd /configure.ac
parentb2f94f9faf805035e4d0e9cb76007204c8250e58 (diff)
parent14e3550348d08d932e0f61a4ae6b8a7afe19a484 (diff)
downloadhdf5-9af344117c2d41886da1f54d3f5cff4091c4a943.zip
hdf5-9af344117c2d41886da1f54d3f5cff4091c4a943.tar.gz
hdf5-9af344117c2d41886da1f54d3f5cff4091c4a943.tar.bz2
[svn-r27794] Reintegration merge of features/autotools_rework branch with trunk
NOTES: - Developers will have to run autogen.sh before building with the autotools. - autogen.sh takes the -p option to mimic the old bin/reconfigure behavior. - The generated error, overflow and version headers have been left in place. - The generated H5LT parser code has also been left in place. - There are no changes for CMake users at this time. Tested on: h5committest
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 10 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index a8e5960..a31b989 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,16 +40,17 @@ AM_INIT_AUTOMAKE([foreign])
AM_SILENT_RULES([yes])
## AM_MAINTAINER_MODE turns off "rebuild rules" that contain dependencies
-## for Makefiles, configure, src/H5config.h, etc. If AM_MAINTAINER_MODE
-## is *not* included here, these files will be rebuilt if out of date.
-## This is a problem because if users try to build on a machine with
+## for Makefiles, configure, src/H5config.h, etc. If AM_MAINTAINER_MODE
+## is enabled, these files will be rebuilt if out of date. This is a
+## problem because if users try to build on a machine with
## the wrong versions of autoconf and automake, these files will be
## rebuilt with the wrong versions and bad things can happen.
## Also, CVS doesn't preserve dependencies between timestamps, so
## Makefiles will often think rebuilding needs to occur when it doesn't.
-## Developers should './configure --enable-maintainer-mode' to turn on
-## rebuild rules.
-AM_MAINTAINER_MODE
+##
+## By default, it is enabled. Users can configure with
+## --disable-maintainer-mode to prevent running the autotools.
+AM_MAINTAINER_MODE([enable])
## ----------------------------------------------------------------------
## Set prefix default (install directory) to a directory in the build area.
@@ -823,8 +824,6 @@ LT_PREREQ([2.2])
## win32-dll - This will build clean dlls on win32 platforms.
LT_INIT([dlopen,win32-dll])
-
-
## ----------------------------------------------------------------------
## Check if we should install only statically linked executables.
## This check needs to occur after libtool is initialized because
@@ -891,32 +890,6 @@ case "X-$RPATH" in
esac
## ----------------------------------------------------------------------
-## pmake will throw an error if variables are undefined in a Makefile.
-## These errors can be changed to warnings using the -V flag.
-##
-AC_SUBST([AM_MAKEFLAGS]) AM_MAKEFLAGS=""
-
-## Don't run test if MAKE is defined but is the empty string
-if test -n "${MAKE-make}"; then
-
- AC_MSG_CHECKING([whether make will build with undefined variables])
-
- cat >maketest <<EOF
-foo: \$(UNDEFINED) \$(UNDEFINED2)
- @echo \$(UNDEFINED3) works
-EOF
-
- if (${MAKE-make} -f maketest foo) >/dev/null 2>&1; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no, setting -V flag])
- AM_MAKEFLAGS="\-V"
- fi
-
- rm maketest
-fi
-
-## ----------------------------------------------------------------------
## Production flags? Save the value in $CONFIG_MODE so we have it for
## the record.
##
@@ -2257,10 +2230,9 @@ fi
## ----------------------------------------------------------------------
## Check if Direct I/O driver is enabled by --enable-direct-vfd
##
-
-## Check these regardless. If the checks are moved inside the main
-## direct VFD block, the output is nested.
-
+## ----------------------------------------------------------------------
+## Check if Direct I/O driver is enabled by --enable-direct-vfd
+##
AC_CACHE_VAL([hdf5_cv_direct_io],
AC_CHECK_DECL([O_DIRECT], [hdf5_cv_direct_io=yes], [hdf5_cv_direct_io=no], [[#include <fcntl.h>]]))
AC_CACHE_VAL([hdf5_cv_posix_memalign],