summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-11-09 20:27:03 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-11-09 20:27:03 (GMT)
commita177131e717e582979de9d5c68856ae630b205ca (patch)
treefff8f42a71114c7480cff806aa93a6fe4b0b0b5f /configure.ac
parentee27a10d497960f26570423ca33909cec2f0326a (diff)
downloadhdf5-a177131e717e582979de9d5c68856ae630b205ca.zip
hdf5-a177131e717e582979de9d5c68856ae630b205ca.tar.gz
hdf5-a177131e717e582979de9d5c68856ae630b205ca.tar.bz2
[svn-r23020] HDFFV-498: lone colon test fails on cygwin and leaves a.exe file on system. Added test for CYGWIN and use a,exe instead of a.out.
Review: HHDF5-1-8-31 Tested: cygwin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e40a1af..eb9ff90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2233,11 +2233,18 @@ AC_CACHE_CHECK([if lone colon can be used as an argument],
[
echo "int main(int argc, char * argv[]) {return 0;}" > conftest.c
$CC $CFLAGS conftest.c > /dev/null 2> /dev/null
- echo "./a.out :" > conftest.sh
+case "`uname`" in
+ CYGWIN*)
+ echo "./a.exe :" > conftest.sh
+ ;;
+ *)
+ echo "./a.out :" > conftest.sh
+ ;;
+esac
chmod 700 conftest.sh
./conftest.sh 2> conftest.out
- rm a.out
+ rm -f a.out a.exe
TEST_OUTPUT=`cat conftest.out`
if test "X$TEST_OUTPUT" = "X"; then