summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-07-28 14:05:39 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-07-28 14:05:39 (GMT)
commitc08ee778588c9e0752e242c201000f1f11a0b742 (patch)
treebf3386ebdb71c56f77285c294601baf6398111a8 /configure.ac
parent92491aa4b6dc2d4fa3c394e0aa928300379e1ced (diff)
downloadhdf5-c08ee778588c9e0752e242c201000f1f11a0b742.zip
hdf5-c08ee778588c9e0752e242c201000f1f11a0b742.tar.gz
hdf5-c08ee778588c9e0752e242c201000f1f11a0b742.tar.bz2
Rearranged where the substitution occurs.
libtool does not pass the correct argument linking (-WL,-WL,,) for the NAG Fortran compiler on Linux (other OSs have not been tested). Therefore, detect if we are using the NAG Fortran compiler, and replace the wl="-Wl," for Fortran to wl="-Wl,-WL,," in the libtool file. (HDFFV-10037)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 25 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 45bd4d1..47f5897 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3339,14 +3339,6 @@ else
fi
if test "X$HDF_FORTRAN" = "Xyes"; then
- ## libtool does not pass the correct argument linker (wl=) for the Intel Fortran compiler
- ## on OS X, which is needed when building shared libraries on OS X. This script
- ## replaces the 3rd occurrence, which is for Fortran, of wl="" with wl="-Wl," (HDFFV-2772)
- case "`uname`" in
- Darwin*)
- cat libtool | awk '/wl=\"/{c++;if(c==3){sub("wl=\"\"","wl=\"-Wl,\"");c=0}}1' > libtool.tmp && mv -f libtool.tmp libtool && chmod 755 libtool
- ;;
- esac
### libtool does not pass the correct argument linking (-WL,-WL,,) for the NAG Fortran compiler
### on Linux (other OSs have not been tested).
@@ -3358,7 +3350,6 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
fortran_linux_linker_option="-Wl,"
if (grep -i 'NAG_Fortran' libtool > /dev/null); then
- cat libtool | awk '/NAG_Fortran/{flag=1}flag&&/wl=/{$NF="wl=\"-Wl,Wl,,\"";flag=0}1' > libtool.tmp && mv -f libtool.tmp libtool && chmod 755 libtool
fortran_linux_linker_option="-Wl,-Wl,,"
fi
@@ -3504,13 +3495,35 @@ AC_CONFIG_COMMANDS([.classes], [], [$MKDIR_P java/src/.classes;
AC_OUTPUT
chmod 755 tools/src/misc/h5cc
-if test "X$HDF_FORTRAN" = "Xyes"; then
- chmod 755 fortran/src/h5fc
-fi
if test "X$HDF_CXX" = "Xyes"; then
chmod 755 c++/src/h5c++
fi
+
+if test "X$HDF_FORTRAN" = "Xyes"; then
+ chmod 755 fortran/src/h5fc
+ ## libtool does not pass the correct argument linker (wl=) for the Intel Fortran compiler
+ ## on OS X, which is needed when building shared libraries on OS X. This script
+ ## replaces the 3rd occurrence, which is for Fortran, of wl="" with wl="-Wl," (HDFFV-2772)
+ case "`uname`" in
+ Darwin*)
+ cat libtool | awk '/wl=\"/{c++;if(c==3){sub("wl=\"\"","wl=\"-Wl,\"");c=0}}1' > libtool.tmp && mv -f libtool.tmp libtool && chmod 755 libtool
+ ;;
+ esac
+
+ ### libtool does not pass the correct argument linking (-WL,-WL,,) for the NAG Fortran compiler
+ ### on Linux (other OSs have not been tested).
+ ### Therefore, detect if we are using the NAG Fortran compiler, and replace the wl="-Wl," for Fortran to
+ ### wl="-Wl,-WL,," in the libtool file. (HDFFV-10037)
+ case "`uname`" in
+ Linux*)
+ if (grep -i 'NAG_Fortran' libtool > /dev/null); then
+ cat libtool | awk '/NAG_Fortran/{flag=1}flag&&/wl=/{$NF="wl=\"-Wl,Wl,,\"";flag=0}1' > libtool.tmp && mv -f libtool.tmp libtool && chmod 755 libtool
+ fi
+ ;;
+ esac
+fi
+
## HDF5 configure code created by autotools with gcc 4.9.2 is adding problematic
## linker flags: -l with no library name; -l <libname>, specifically gfortran or m.
## This sed script corrects "-l <libname>" first and then "-l " with no library name.