summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-25 21:33:48 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-25 21:33:48 (GMT)
commitd3114a96da64de8ea987f7c1714f8ad4a2474f4e (patch)
tree5f55455b9e0520291f52daed4d5d28348a189578 /configure.ac
parent597c3c089b022d967a59b0ab199c73e144417c79 (diff)
downloadhdf5-d3114a96da64de8ea987f7c1714f8ad4a2474f4e.zip
hdf5-d3114a96da64de8ea987f7c1714f8ad4a2474f4e.tar.gz
hdf5-d3114a96da64de8ea987f7c1714f8ad4a2474f4e.tar.bz2
[svn-r26591] Description:
Bring r26492 from autotools_rework branch back to trunk: Remove the FP_TO_ULLONG_ACCURATE and FP_TO_ULLONG_RIGHT_MAXIMUM macros/defines, which were added to address problems with older PGI compilers and HP-UX systems and are no longer supported. Tested on: Linux/32 2.6.18 (jam) w/serial & parallel (daily tested on branch for >1 week)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac81
1 files changed, 0 insertions, 81 deletions
diff --git a/configure.ac b/configure.ac
index bf74348..4777ce2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2576,87 +2576,6 @@ esac
## ----------------------------------------------------------------------
## Set the flag to indicate that the machine can accurately convert
-## 'float' or 'double' to 'unsigned long long' values.
-## (This flag should be set for all machines, except for PGI compiler
-## where round-up happens when the fraction of float-point value is greater
-## than 0.5.
-##
-AC_MSG_CHECKING([if accurately roundup converting floating-point to unsigned long long values])
-
-AC_CACHE_VAL([hdf5_cv_fp_to_ullong_accurate],
- [AC_TRY_RUN([
- int main(void)
- {
- float f = 111.60f;
- double d = 222.55L;
- unsigned long long l1 = (unsigned long long)f;
- unsigned long long l2 = (unsigned long long)d;
- int ret = 0;
-
- if(l1 == 112)
- ret = 1;
- if(l2 == 223)
- ret = 1;
-
-done:
- exit(ret);
- }
- ], [hdf5_cv_fp_to_ullong_accurate=yes], [hdf5_cv_fp_to_ullong_accurate=no],)])
-
-if test ${hdf5_cv_fp_to_ullong_accurate} = "yes"; then
- AC_DEFINE([FP_TO_ULLONG_ACCURATE], [1],
- [Define if your system roundup accurately converting floating-point to unsigned long long values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can accurately convert
-## 'float', 'double' or 'long double' to 'unsigned long long' values.
-## (This flag should be set for all machines, except for HP-UX machines
-## where the maximal number for unsigned long long is 0x7fffffffffffffff
-## during conversion.
-##
-AC_MSG_CHECKING([if right maximum converting floating-point to unsigned long long values])
-
-AC_CACHE_VAL([hdf5_cv_fp_to_ullong_right_maximum],
- [AC_TRY_RUN([
- int main(void)
- {
- float f = 9701917572145405952.00f;
- double d1 = 9701917572145405952.00L;
- long double d2 = 9701917572145405952.00L;
- double d3 = 2e40L;
- unsigned long long l1 = (unsigned long long)f;
- unsigned long long l2 = (unsigned long long)d1;
- unsigned long long l3 = (unsigned long long)d2;
- unsigned long long l4;
- unsigned long long l5 = 0x7fffffffffffffffULL;
- int ret = 0;
-
- if(l1 <= l5 || l2 <= l5 || l3 <= l5)
- ret = 1;
-
- l4 = (unsigned long long)d3;
- if(l4 <= l5)
- ret = 1;
-
-done:
- exit(ret);
- }
- ], [hdf5_cv_fp_to_ullong_right_maximum=yes], [hdf5_cv_fp_to_ullong_right_maximum=no],)])
-
-if test ${hdf5_cv_fp_to_ullong_right_maximum} = "yes"; then
- AC_DEFINE([FP_TO_ULLONG_RIGHT_MAXIMUM], [1],
- [Define if your system has right maximum convert floating-point to unsigned long long values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can accurately convert
## 'long double' to 'unsigned int' values. (This flag should be set for
## all machines, except for some Intel compilers on some Linux.)
##