summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2023-09-22 13:41:57 (GMT)
committerGitHub <noreply@github.com>2023-09-22 13:41:57 (GMT)
commitdece6256bff8ee8b04ed63376233c03568e4edb1 (patch)
tree6aa4b07c66a1294ef067041a71b93538ec0ab045 /configure.ac
parent16ac8f74d4fa72c9092b6701bca1328770aa9dbe (diff)
downloadhdf5-dece6256bff8ee8b04ed63376233c03568e4edb1.zip
hdf5-dece6256bff8ee8b04ed63376233c03568e4edb1.tar.gz
hdf5-dece6256bff8ee8b04ed63376233c03568e4edb1.tar.bz2
Adds link to h5fuse.sh in testpar for autotools (#3557)
* Make the h5fuse.sh utility available to parallel subfiling tests so h5fuse testing is not skipped.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fadd1c1..15f7bb4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4206,6 +4206,11 @@ AC_CONFIG_FILES([Makefile
hl/fortran/examples/run-hlfortran-ex.sh])
AC_CONFIG_FILES([utils/subfiling_vfd/h5fuse.sh], [chmod +x utils/subfiling_vfd/h5fuse.sh])
+if test -n "$TESTPARALLEL"; then
+ if test "X$SUBFILING_VFD" = "Xyes"; then
+ AC_CONFIG_LINKS([testpar/h5fuse.sh:utils/subfiling_vfd/h5fuse.sh])
+ fi
+fi
AC_CONFIG_COMMANDS([.classes], [], [$MKDIR_P java/src/.classes;
$MKDIR_P java/test/.classes;