summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuincey Koziol <koziol@hdfgroup.org>2015-03-27 16:34:08 (GMT)
committerQuincey Koziol <koziol@hdfgroup.org>2015-03-27 16:34:08 (GMT)
commite30b4b17cfd56d9e50786d6dc99b8323e1e86bc2 (patch)
tree54cea90c215a8b1c621c26b550c35f03eb270ae4 /configure.ac
parent037f8104e8bb50313405ae7d3a1a8695584c8d40 (diff)
downloadhdf5-e30b4b17cfd56d9e50786d6dc99b8323e1e86bc2.zip
hdf5-e30b4b17cfd56d9e50786d6dc99b8323e1e86bc2.tar.gz
hdf5-e30b4b17cfd56d9e50786d6dc99b8323e1e86bc2.tar.bz2
[svn-r26618] Description:
Bring r26511 from autotools_rework branch to trunk: Remove the FP_TO_INTEGER_OVERFLOW_WORKS macro/define, which is for working around bugs in the Cray X1 compiler and is no longer supported. Tested on: Linux/32 2.6.18 (jam) w/serial & parallel (Daily tested on branch for 2+ days)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index 7aa503c..2b821a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2541,37 +2541,6 @@ case "`uname`" in
esac
## ----------------------------------------------------------------------
-## Set the flag to indicate that the machine can handle overflow converting
-## all floating-point to all integer types.
-## (This flag should be set for all machines, except for Cray X1 where
-## floating exception is generated when the floating-point value is greater
-## than the maximal integer value).
-##
-AC_MSG_CHECKING([if overflows normally converting floating-point to integer values])
-
-AC_CACHE_VAL([hdf5_cv_fp_to_integer_overflow_works],
- [AC_TRY_RUN([
- int main(void)
- {
- float f = 2147483648.0f;
- int i;
-
- i = (int)f;
-
-done:
- exit(0);
- }
- ], [hdf5_cv_fp_to_integer_overflow_works=yes], [hdf5_cv_fp_to_integer_overflow_works=no],)])
-
-if test ${hdf5_cv_fp_to_integer_overflow_works} = "yes"; then
- AC_DEFINE([FP_TO_INTEGER_OVERFLOW_WORKS], [1],
- [Define if your system can handle overflow converting floating-point to integer values.])
- AC_MSG_RESULT([yes])
-else
- AC_MSG_RESULT([no])
-fi
-
-## ----------------------------------------------------------------------
## Set the flag to indicate that the machine is using a special algorithm to convert
## 'long double' to '(unsigned) long' values. (This flag should only be set for
## the IBM Power6 Linux. When the bit sequence of long double is