summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-12-24 19:36:38 (GMT)
committerGitHub <noreply@github.com>2022-12-24 19:36:38 (GMT)
commit1cf9ecccf519663e9a7178bb59831dc5426f1080 (patch)
tree0bb255a33a400e7e222aa71e743b461af4618ec9 /configure.ac
parentcfd5059e77e2e411a94a13d2fb033224736be09d (diff)
downloadhdf5-1cf9ecccf519663e9a7178bb59831dc5426f1080.zip
hdf5-1cf9ecccf519663e9a7178bb59831dc5426f1080.tar.gz
hdf5-1cf9ecccf519663e9a7178bb59831dc5426f1080.tar.bz2
Fix for Autotools --disable-deprecated-symbols (#2363)
* Fix for Autotools --disable-deprecated-symbols When we added v116 as a valid option, we left the default as v114 so using --disable-deprecated-symbols leads configure to complain that you can't set a default API that was deprecated. The GitHub action didn't catch this because it explicitly specifies v116 This only affects develop w/ the Autotools when --disable-deprecated-symbols is requested. * Added v116 & default to the --with-default-api-version help string The Autotools --with-default-api-version help string was missing v116. This has been added, as well as a "default" target so the CI can catch version problems when we forget to update the defaults upon creating a new major version. The GitHub CI also now uses "default" as the target for the deprecated symbols build. * Fixes the 1.14 API GitHub CI threadsafe/build_mode This action still had the bug we fixed where we set the build mode and threadsafety using an array of size one instead of an object.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 35db84b..b34355c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3749,11 +3749,13 @@ esac
AC_SUBST([DEFAULT_API_VERSION])
AC_MSG_CHECKING([which version of public symbols to use by default])
AC_ARG_WITH([default-api-version],
- [AS_HELP_STRING([--with-default-api-version=(v16|v18|v110|v112|v114)],
+ [AS_HELP_STRING([--with-default-api-version=(default|v16|v18|v110|v112|v114|v116)],
[Specify default release version of public symbols
- [default=v114]])],,
- [withval=v114])
+ [default=v116]])],,
+ [withval=v116])
+## Allowing "default" allows the GitHub CI to check that we didn't forget
+## to change the defaults when creating a new major version
if test "X$withval" = "Xv16"; then
AC_MSG_RESULT([v16])
DEFAULT_API_VERSION=v16
@@ -3779,7 +3781,7 @@ elif test "X$withval" = "Xv114"; then
DEFAULT_API_VERSION=v114
AC_DEFINE([USE_114_API_DEFAULT], [1],
[Define using v1.14 public API symbols by default])
-elif test "X$withval" = "Xv116"; then
+elif test "X$withval" = "Xv116" -o "X$withval" = "Xdefault"; then
AC_MSG_RESULT([v116])
DEFAULT_API_VERSION=v116
AC_DEFINE([USE_116_API_DEFAULT], [1],