summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2024-03-12 18:30:24 (GMT)
committerGitHub <noreply@github.com>2024-03-12 18:30:24 (GMT)
commit8123614b4d9e814f64e5bd325ccaead5bb76e003 (patch)
tree0b4f0fcf1adce2c3ee9baf2eb9a96e6f35417e2d /configure.ac
parent40cb71d4c2e41937a216c06b78e8e345955469e2 (diff)
downloadhdf5-8123614b4d9e814f64e5bd325ccaead5bb76e003.zip
hdf5-8123614b4d9e814f64e5bd325ccaead5bb76e003.tar.gz
hdf5-8123614b4d9e814f64e5bd325ccaead5bb76e003.tar.bz2
Use AC_SYS_LARGEFILE on Autotools (#4119)
We previously used a hack introduced in 1.8.5 to paper over differences in off_t and off64_t when determining the type sizes. We no longer explicitly support off64_t in the library and AC_SYS_LARGEFILE works fine.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 3 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 4646ba7..0fa2b3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1460,26 +1460,9 @@ if test "X${enable_shared}" = "Xyes"; then
fi
## ----------------------------------------------------------------------
-## Use the macro _AC_SYS_LARGEFILE_MACRO_VALUE to test defines
-## that might need to be set for largefile support to behave
-## correctly. This macro is defined in acsite.m4 and overrides
-## the version provided by Autoconf (as of v2.65). The custom
-## macro additionally adds the appropriate defines to AM_CPPFLAGS
-## so that later configure checks have them visible.
-
-## Check for _FILE_OFFSET_BITS
-_AC_SYS_LARGEFILE_MACRO_VALUE([_FILE_OFFSET_BITS], [64],
- [ac_cv_sys_file_offset_bits],
- [Number of bits in a file offset, on hosts where this is settable.],
- [_AC_SYS_LARGEFILE_TEST_INCLUDES])
-
-## Check for _LARGE_FILES
-if test "$ac_cv_sys_file_offset_bits" = unknown; then
- _AC_SYS_LARGEFILE_MACRO_VALUE([_LARGE_FILES], [1],
- [ac_cv_sys_large_files],
- [Define for large files, on AIX-style hosts.],
- [_AC_SYS_LARGEFILE_TEST_INCLUDES])
-fi
+## Set up large file support
+
+AC_SYS_LARGEFILE
## ----------------------------------------------------------------------
## Add necessary defines for Linux Systems.