summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-08-23 15:21:33 (GMT)
committerGitHub <noreply@github.com>2023-08-23 15:21:33 (GMT)
commit81fc47cc06dd162940b39b99b25c3708db026b0a (patch)
treefdc5a36281340ed418b92fd9ab61ad239265d7e1 /configure.ac
parentf61522ec4d080c6a62285bd530b4851e03771014 (diff)
downloadhdf5-81fc47cc06dd162940b39b99b25c3708db026b0a.zip
hdf5-81fc47cc06dd162940b39b99b25c3708db026b0a.tar.gz
hdf5-81fc47cc06dd162940b39b99b25c3708db026b0a.tar.bz2
Enable szip by default in Autotools (#3412)
Since libaec is so prevalent and BSD-licensed for both encode and decode, we build the szip filter by default when the szip or aec libraries are found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d669bea..c0eb47c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1561,7 +1561,7 @@ AC_ARG_WITH([fnord],
## ----------------------------------------------------------------------
## Make the external filters list available to *.in files
## At this point it's unset (no external filters by default) but it
-## will be filled in during the deflate (zlib) and szip processing
+## will be filled in during the deflate/zlib and szip/libaec processing
## below.
##
AC_SUBST([EXTERNAL_FILTERS])
@@ -1666,13 +1666,18 @@ fi
## command-line switch. The value is an include path and/or a library path.
## If the library path is specified then it must be preceded by a comma.
##
+## libaec also implements Space Data System Standard 121.0-B-2 and has
+## an szip compatibility header. Since the AEC library is BSD licensed
+## for both encoding and decoding, we now build with the filter enabled
+## by default when the library is found.
+##
AC_SUBST([LL_PATH])
AC_SUBST([USE_FILTER_SZIP]) USE_FILTER_SZIP="no"
AC_ARG_WITH([szlib],
[AS_HELP_STRING([--with-szlib=DIR],
[Use szlib library for external szlib I/O
- filter [default=no]])],,
- [withval=no])
+ filter [default=yes]])],,
+ [withval=yes])
case "X-$withval" in
X-yes)