summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-12-21 18:07:25 (GMT)
committerGitHub <noreply@github.com>2022-12-21 18:07:25 (GMT)
commit9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab (patch)
tree2f237d0865fa37db7ad56d7182978db4258488fa /configure.ac
parent976e8c97504cfbce40c565b02a01d29006350c6b (diff)
downloadhdf5-9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab.zip
hdf5-9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab.tar.gz
hdf5-9f5cf0a45748fcb7ced4f4619d7c6c76cb3f67ab.tar.bz2
H5F_LIBVER_LATEST changes for move to 1.15 (#2288)
* H5F_LIBVER_LATEST changes for move to 1.15 * Add new default api check * Format fixes * Fix default configure * fix lib version tests * Fix another version variable * Add 1.14 doc link
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5f62140..3d82c20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ AC_PREREQ([2.69])
## NOTE: Do not forget to change the version number here when we do a
## release!!!
##
-AC_INIT([HDF5], [1.13.4-1], [help@hdfgroup.org])
+AC_INIT([HDF5], [1.15.0], [help@hdfgroup.org])
AC_CONFIG_SRCDIR([src/H5.c])
AC_CONFIG_HEADERS([src/H5config.h])
@@ -3789,6 +3789,11 @@ elif test "X$withval" = "Xv114"; then
DEFAULT_API_VERSION=v114
AC_DEFINE([USE_114_API_DEFAULT], [1],
[Define using v1.14 public API symbols by default])
+elif test "X$withval" = "Xv116"; then
+ AC_MSG_RESULT([v116])
+ DEFAULT_API_VERSION=v116
+ AC_DEFINE([USE_116_API_DEFAULT], [1],
+ [Define using v1.16 public API symbols by default])
else
AC_MSG_ERROR([invalid version of public symbols given])
fi
@@ -3798,7 +3803,7 @@ fi
## if the user insists on doing this via the --enable-unsupported configure
## flag, we'll let them.
if test "X${ALLOW_UNSUPPORTED}" != "Xyes"; then
- if test "X${DEFAULT_API_VERSION}" != "Xv114" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
+ if test "X${DEFAULT_API_VERSION}" != "Xv116" -a "X${DEPRECATED_SYMBOLS}" = "Xno" ; then
AC_MSG_ERROR([Removing old public API symbols not allowed when using them as default public API symbols. Use --enable-unsupported to override this error.])
fi
fi