summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2022-12-24 00:05:31 (GMT)
committerGitHub <noreply@github.com>2022-12-24 00:05:31 (GMT)
commitcfd5059e77e2e411a94a13d2fb033224736be09d (patch)
treec81153efc8899be0ba197d0ae1355d55351cbd03 /configure.ac
parent9a694db450d3d62d63910887bd8485ae76124807 (diff)
downloadhdf5-cfd5059e77e2e411a94a13d2fb033224736be09d.zip
hdf5-cfd5059e77e2e411a94a13d2fb033224736be09d.tar.gz
hdf5-cfd5059e77e2e411a94a13d2fb033224736be09d.tar.bz2
HL GIF tools changes (#2360)
* Fixes the broken Autotools option * Removes the "build HL tools" option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 21 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 3d82c20..35db84b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -874,37 +874,6 @@ else
AC_MSG_RESULT([no])
fi
-AC_MSG_CHECKING([if the high-level tools are enabled])
-AC_ARG_ENABLE([hltools],
- [AS_HELP_STRING([--enable-hltools],
- [Enable the high-level tools.
- [default=yes]
- ])],
- [HDF5_HL_TOOLS=$enableval])
-
-if test "X${HDF5_HL}" = "Xyes" -a "X-$HDF5_HL_TOOLS" = "X-yes"; then
- AC_MSG_RESULT([yes])
- HL_TOOLS="tools"
-else
- AC_MSG_RESULT([no])
-fi
-
-AC_MSG_CHECKING([if the high-level GIF tools are enabled])
-AC_ARG_ENABLE([hltools],
- [AS_HELP_STRING([--enable-hlgiftools],
- [Enable the high-level GIF tools.
- [default=no]
- ])],
- [HDF5_HL_GIF_TOOLS=$enableval])
-
-if test "X${HDF5_GIF_HL}" = "Xyes" -a "X-$HDF5_HL_TOOLS" = "X-yes" -a "X-$HDF5_HL_GIF_TOOLS" = "X-yes"; then
- AC_MSG_RESULT([yes])
- HL_GIF_TOOLS="tools"
-else
- AC_MSG_RESULT([no])
-fi
-
-
## ----------------------------------------------------------------------
## Enable new references for dimension scales
##
@@ -1196,6 +1165,27 @@ AC_ARG_ENABLE([tools],
AC_MSG_RESULT([$HDF5_TOOLS])
## ----------------------------------------------------------------------
+## Check if they would like to disable building the high-level GIF
+## tools (they have unfixed CVE issues)
+##
+
+AC_MSG_CHECKING([if the high-level GIF tools are enabled])
+AC_ARG_ENABLE([hlgiftools],
+ [AS_HELP_STRING([--enable-hlgiftools],
+ [Enable the high-level GIF tools. NOTE: These have unfixed CVE issues!
+ [default=no]
+ ])],
+ [HDF5_HL_GIF_TOOLS=$enableval])
+
+if test "X-$HDF5_TOOLS" = "X-yes" -a "X-$HDF5_HL" = "X-yes" -a "X-$HDF5_HL_GIF_TOOLS" = "X-yes"; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+ HDF5_HL_GIF_TOOLS="no"
+fi
+
+
+## ----------------------------------------------------------------------
## Check if they would like to enable building doxygen files
##
@@ -3927,7 +3917,6 @@ AM_CONDITIONAL([BUILD_HDF5_HL_CONDITIONAL], [test "X$HDF5_HL" = "Xyes"])
AM_CONDITIONAL([BUILD_TESTS_CONDITIONAL], [test "X$HDF5_TESTS" = "Xyes"])
AM_CONDITIONAL([BUILD_TESTS_PARALLEL_CONDITIONAL], [test -n "$TESTPARALLEL"])
AM_CONDITIONAL([BUILD_TOOLS_CONDITIONAL], [test "X$HDF5_TOOLS" = "Xyes"])
-AM_CONDITIONAL([BUILD_TOOLS_HL_CONDITIONAL], [test "X$HDF5_HL_TOOLS" = "Xyes"])
AM_CONDITIONAL([BUILD_TOOLS_HL_GIF_CONDITIONAL], [test "X$HDF5_HL_GIF_TOOLS" = "Xyes"])
AM_CONDITIONAL([BUILD_DOXYGEN_CONDITIONAL], [test "X$HDF5_DOXYGEN" = "Xyes"])