summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2023-06-13 15:16:41 (GMT)
committerGitHub <noreply@github.com>2023-06-13 15:16:41 (GMT)
commitd4605919f970e2f84d00d802f1b01db1b98fafc6 (patch)
treee6699bf07edd54ceacf5741941c327d497b2e29f /configure.ac
parent9e7e2f8b8edc868b50e6d004f37ce1a2bf9da3f9 (diff)
downloadhdf5-d4605919f970e2f84d00d802f1b01db1b98fafc6.zip
hdf5-d4605919f970e2f84d00d802f1b01db1b98fafc6.tar.gz
hdf5-d4605919f970e2f84d00d802f1b01db1b98fafc6.tar.bz2
Remove H5detect and H5make_libsettings (#3104)
Removes H5detect and H5make_libsettings from the build and replaces their functionality with things that don't affect cross-compiling. H5detect --> floating-point types are now detected on library load H5make_libsettings --> Moved functionality to a new H5build_settings.c template file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 19 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index fc438d4..ae5dffd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,14 +81,21 @@ AM_MAINTAINER_MODE([enable])
## This allows multiple src-dir builds within one host.
AC_PREFIX_DEFAULT([`pwd`/hdf5])
-## Run post processing on files created by configure.
+## Run post processing on files created by configure
+##
## src/H5pubconf.h:
## Generate src/H5pubconf.h from src/H5config.h by prepending H5_ to all
## macro names. This avoid name conflict between HDF5 macro names and those
## generated by another software package that uses the HDF5 library.
+##
## src/libhdf5.settings:
-## Remove all lines begun with "#" which are generated by CONDITIONAL's of
-## configure.
+## Remove all lines beginning with "#" which are generated by CONDITIONAL's
+## of configure.
+##
+## src/H5build_settings.c
+## Remove all lines beginning with "#" which are generated by CONDITIONAL's
+## of configure. This uses a check for whitespace after the pound sign
+## to avoid clobbering include statements.
AC_CONFIG_COMMANDS([pubconf], [
echo "creating src/H5pubconf.h"
sed 's/#define /#define H5_/' <src/H5config.h |\
@@ -105,6 +112,10 @@ AC_CONFIG_COMMANDS([pubconf], [
sed '/^#/d' < src/libhdf5.settings > libhdf5.settings.TMP
cp libhdf5.settings.TMP src/libhdf5.settings
rm -f libhdf5.settings.TMP
+ echo "Post process src/H5build_settings.c"
+ sed '/^# /d' < src/H5build_settings.c > H5build_settings.TMP
+ cp H5build_settings.TMP src/H5build_settings.c
+ rm -f H5build_settings.TMP
])
## It's possible to configure for a host other than the one on which
@@ -3725,9 +3736,11 @@ AC_ARG_ENABLE([embedded-libinfo],
if test "${enable_embedded_libinfo}" = "yes"; then
AC_MSG_RESULT([yes])
+ BUILD_SETTINGS_FILE="src/H5build_settings.autotools.c.in"
AC_DEFINE([HAVE_EMBEDDED_LIBINFO], [1],
[Define if library information should be embedded in the executables])
else
+ BUILD_SETTINGS_FILE="src/H5build_settings.off.c.in"
AC_MSG_RESULT([no])
fi
@@ -3860,10 +3873,11 @@ fi
##
AM_CONDITIONAL([HAVE_SHARED_CONDITIONAL], [test "X$enable_shared" = "Xyes"])
-AC_CONFIG_FILES([src/libhdf5.settings
- Makefile
+AC_CONFIG_FILES([Makefile
doxygen/Doxyfile
src/Makefile
+ src/libhdf5.settings
+ src/H5build_settings.c:${BUILD_SETTINGS_FILE}
test/Makefile
test/H5srcdir_str.h
test/test_abort_fail.sh