summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDana Robinson <43805+derobins@users.noreply.github.com>2021-06-23 19:08:04 (GMT)
committerGitHub <noreply@github.com>2021-06-23 19:08:04 (GMT)
commitd79c650a5ed08c5b16203f7c6a40809eed830de7 (patch)
treea1f9b9341e7db98adc9758d91a41be58d2b5ef90 /configure.ac
parentcc88fe8fafa0a522ba583bf75b2fe9a15688db9c (diff)
downloadhdf5-d79c650a5ed08c5b16203f7c6a40809eed830de7.zip
hdf5-d79c650a5ed08c5b16203f7c6a40809eed830de7.tar.gz
hdf5-d79c650a5ed08c5b16203f7c6a40809eed830de7.tar.bz2
Further simplifies Autotools type size checks (#789)
Also fixes an issue where clock_gettime and difftime are not detected due to earlier simplifications of this code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 2 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index b5f4fe1..cfd9d0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1351,16 +1351,6 @@ CFLAGS="$H5_CFLAGS $AM_CFLAGS $CFLAGS"
## Checkpoint the cache
AC_CACHE_SAVE
-## Write the confdefs.h header for checking sizes
-cat >>confdefs.h <<\EOF
-#include <stdbool.h>
-#include <stdint.h>
-#ifdef HAVE_UNISTD_H
-#include <sys/types.h>
-#endif
-#include <time.h>
-EOF
-
AC_CHECK_SIZEOF( [int8_t])
AC_CHECK_SIZEOF( [uint8_t])
AC_CHECK_SIZEOF( [int_least8_t])
@@ -1389,12 +1379,12 @@ AC_CHECK_SIZEOF([uint_least64_t])
AC_CHECK_SIZEOF( [int_fast64_t])
AC_CHECK_SIZEOF( [uint_fast64_t])
-AC_CHECK_SIZEOF([bool])
+AC_CHECK_SIZEOF([bool], [], [#include <stdbool.h>])
AC_CHECK_SIZEOF([off_t])
AC_CHECK_SIZEOF([ptrdiff_t])
AC_CHECK_SIZEOF([size_t])
AC_CHECK_SIZEOF([ssize_t])
-AC_CHECK_SIZEOF([time_t])
+AC_CHECK_SIZEOF([time_t], [], [#include <time.h>])
## Checkpoint the cache
AC_CACHE_SAVE